0

I've installed Elementary OS Loki on my laptop yesterday. At the beginning everything was OK.

But last night after some installation and system updates I cannot shutdown Elementary OS.

When I shutdown Elementary OS, after turning screen off the system just goes crazy, fan running at full speed and processor almost screaming.

If I leave it in this case a while and then hard shut down manually, some times the laptop cannot found SSD at first running. After manually restart, everything goes well.

I've tried to figured out what happened by reviewing /var/log/syslog file. But nothing caught my attention.

I had read that Ubuntu 16.04 has a SAMBA bug which causes a similar issue. Then I run the command of sudo chmod 744 /usr/lib/gvfs/gvfsd-smb-browse as directed over here. But it didn't work on my case.

Is there any chance to overcome this issue ?

I cannot shutdown Elementary OS properly.

  • Out of curiosity, what process(es) is(are) hogging the cpu? – Paritosh Nov 26 '16 at 5:32
  • @Paritosh, really I couldn't figure it out. The last time I encountered the same issue. How to know which process(es) cause(s) this issue? I cannot see relevant something in syslog. – efkan Nov 26 '16 at 7:30
  • Short answer is edit GRUB during boot and delete "quiet splash". Now when you shutdown, you'll be able to see what the OS is doing and hopefully what's stopping from shutting down. Long answer - Check this answer for steps to edit GRUB askubuntu.com/a/6128/615353 Note that I have tried this and it is working in Elementary OS Loki just fine. – Paritosh Nov 26 '16 at 19:57
  • I've re-installed a couple of hours ago my laptop. The laptop has hp uefi. I didn't get updates yet :) For now everything is OK. Actually I wonder what will happen after getting updates. – efkan Nov 26 '16 at 22:20
  • 1
    Aha. The thing with updates is there isn't a change log available to see what exactly was changed. So you are still at the mercy of updates gelling in well with your system. – Paritosh Nov 27 '16 at 0:51
0

I have this problem with sleep and suspend on a desktop tower, I haven't had this problem before. I am running a relatively new install/ elementary OS 0.3.2 Freya 64. Have tried setting from BIOS and result is same. I don't like messing with the system without knowing what I'm doing. I could re-install but it's a hassle and this is the only problem (touch wood). I'd prefer a work-around. It only suspends if I do it manually from desktop. I have to press power button on my tower to un-suspend. I set all the options in system settings but it has no effect. CPU is 4 cores and no sign of sleeping. I have not suffered this issue before. The above comment with code is Intel - mine is AMD - this is op-sys not hardware issue.

  • The problem was related system updates (It may is not an issue maybe it's my ignorance) . I can say that after system updates I encounter other issues (wifi and sound). Again, maybe it is related my hardware. But for now, I won't update my Elementary OS. I don't want to deal with another issue. If I change the operating system to Ubuntu, I do not know if I have similar problems. Probably "yes". – efkan Nov 28 '16 at 12:01
0

I've downgraded the linux kernel to get rid of this issue!

sudo apt-get purge linux-image-4.4.0-51-generic

Now my kernel version is 4.4.0-38-generic and there is no any shutdown issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.