1

I have just reinstalled my laptop from Windows 10 to elementary OS 0.4 Loki. In Windows 10, my touchpad works but just the basics (point & click, no two-finger gestures). But in Loki, even from the live session running from my USB drive, the touchpad would stop working after a while, usually about 5-10 seconds from login. In that 5 to 10 seconds, the touchpad works flawlessly, even two-finger gestures. But after that, suddenly it kind of freezes there, not registering my taps and clicks.

My laptop is Acer Aspire E5-552G-F6X5. My touchpad driver is Synaptics.

I have tried a few ways to fix it, but to no avail:

  1. Editing the /etc/default/grub by running this code:
    sudo nano /etc/default/grub
    and then changing the line:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet nosplash"
    to:
    GRUB_CMDLINE_LINUX_DEFAULT="i8042.nomux i8042.reset quiet nosplash"
    This doesn't fix my touchpad problems.
  2. Disabling libinput and forcing eOS to use Synaptics by using these codes:
    sudo apt-get install xserver-xorg-input-synaptics
    sudo mkdir /etc/X11/xorg.conf.d
    sudo cp /usr/share/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d

    The code gives me error at the mkdir part, where it says:
    mkdir: cannot create directory ‘/etc/X11/xorg.conf.d’: File exists
  3. Removing the libinput drivers and installs the Synaptics driver by running these codes:
    sudo apt-get remove xserver-xorg-input-libinput libinput-tools
    Then:
    sudo apt-get install xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-synaptics
    This also failed to fix my touchpad problems.
  4. Running sudo modprobe -r psmouse followed by sudo modprobe psmouse, which also failed to fix it.

Most interesting here is the fact that if I ran xinput list, the touchpad is shown there as:
⎜ ↳ SYN1B81:01 06CB:7406 Touchpad id=12 [slave pointer (2)]

I have looked all over internet for the solution of this problem. I'm completely new to the Linux environment, and chose eOS for its ease of use. Actually, I expected eOS to work with this laptop's touchpad out of the box. My question is, what I must do to fix it?

Thank you very much beforehand.

  • try "sudo cp /usr/share/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d/50-synaptics.conf" also look inside this file. You may need to change the driver under touchpad from Driver "libinput" to Driver "synaptics". If I remember correctly, anything ins /usr/share/X11/xorg.conf.d will override whats in /etc/X11/xorg.conf.d so change the one in /usr/share to. You can do this in the terminal with sudo nano location/filename – Michael Roberts Nov 24 '16 at 3:13
  • I'm sorry, but as I've said, I'm new to the Linux environment. I don't really understand what files that I needed to change in /usr/share. Can you explain in detail? – Erick Nov 24 '16 at 4:22
  • I was referring to /usr/share/X11/xorg.conf.d/50-synaptics.conf the command to edit in the terminal would be "sudo nano /usr/share/X11/xorg.conf.d/50-synaptics.conf" change the driver from "libinput" to "synaptics" then hit ctrl+x to close nano and "y" when it ask if you want to save the changes. – Michael Roberts Nov 24 '16 at 6:56
  • @MichaelRoberts I have tried what you've said, using sudo nano /usr/share/X11/xorg.conf.d/50-synaptics.conf and sudo nano /etc/X11/xorg.conf.d/50-synaptics.conf to take a look at those files. In all of them, the "driver" is already Synaptics. I also tried sudo cp /usr/share/X11/xorg.conf.d/50-synaptics.conf /etc/X11/xorg.conf.d/50-synaptics.conf but it didn't seem to do anything. – Erick Nov 24 '16 at 7:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.