I installed an Windows 7 Virtual Machine and everything is working fine, but to be able to identify USB devices inside my guest system it needs a function called "Groups" described here that can be activated in Ubuntu. I tried to install in Freya but it didnt work at all (the menu option didnt apear and I'm not able to set all needed configuration). I wasnt able to find an specific solution that works in Elementary so here I am asking to you if you know any solution.

2 Answers 2


Steps to enable USB support for vbox:

  1. Install the appropriate vbox extension pack
  2. Open terminal and execute this command

    sudo usermod -a -G vboxusers $USER

  3. Go to settings > usb

  4. Tick USB controller and USB 2.0 controller

  5. Add an USB device filter.


The simple GUI solution:

  • Install gnome-system-tools from software center or with terminal command:

    sudo apt-get install gnome-system-tools
  • Open users and groups


  • Select the user ( your user name, if multiple users present) and click on Manage Groups.

    A pop-up will appear, select vboxusers and click on properties


  • Now check (enable) your user name.


  • logout and login.

Now open vbox --> settings --> Usb



You can also enable via advanced options in users and groups.

Go to advanced options --> User privileges tab --> check Use Virtualbox virtualization solution (last in the list)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.