1

This question is an exact duplicate of:

I've tried to install loki on a Macbook 12" 2015, but once the Install screen loads, neither trackpad or keyboard respond.

I've managed to install it without problems on an external USB disk (using rEFInd) using a Macbook pro 15" 2014, in order to use it on both Macs, and after that, if I try to boot it using the Macbook 12", it still doesn't work (no keyboard or trackpad, can pass login screen). However, the macbookpro works flawlessly.

I guess it's drivers related, but I though it would be compatible. Any hint on this? I haven't found much info about it.

Thanks

marked as duplicate by Lewis Goddard Feb 20 at 1:29

This question was marked as an exact duplicate of an existing question.

  • I'm joining you in your quest hopping to get an answer as well (before installing anything...). I have an Early 2016 Macbook 12 (m5) and I'm not sure whether I will be able to install ElementaryOS or not? I mean, install it will be no problem I guess... Will my "Config" be able to run ElementaryOS? Thanks in advance! – Ardzii Nov 21 '16 at 11:41
  • Make that two. I'm stuck there as well. – Jean Le Moignan Jan 1 '17 at 22:54
  • I have a 2017 13" MacBook Pro with the same problem. – Alfred Jul 13 '18 at 10:18
0

I simply ran these commands and it works pretty well! Nothing else was needed.

Go root first by executing sudo -i or sudo su in the terminal and then execute the commands bellow,

echo -e "\n# applespi\napplespi\nspi_pxa2xx_platform\nspi_pxa2xx_pci" >> /etc/initramfs-tools/modules
apt install dkms git
git clone https://github.com/cb22/macbook12-spi-driver.git /usr/src/applespi-0.1
dkms install -m applespi -v 0.1
shutdown -r now

Not the answer you're looking for? Browse other questions tagged or ask your own question.