2

I recently had Elementary OS (Loki) installed in my Asus UX305 (Dual Boot option). Out of the box, the notebook came with windows 10 home. I took some body's help in the installation as it was not straight forward for me. Iam new to Linux. Post installation, it has been a mixed experience. The positives noted in many reviews are definitely there.

However, when I plug in a USB device, it is not recognized. Neither the 'Files' side bar nor 'Disks' show the device being connected. 'sudo fdisk -l' command too does not reveal the USB device. To detect the device, I have to do either of the folowing: a) suspend the system and wake it up (b) turn off the computer and restart. This issue is observed whether I use the USB-3 or USB-2 ports.

output of sudo lsusb Before And After device insertion (when device is not seen):

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 001 Device 003: ID 8087:0a2a Intel Corp.

Bus 001 Device 002: ID 04f2:b56b Chicony Electronics Co., Ltd

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Has any one of you faced this issue? Please help...I am even thinking of shifting to Ubuntu from this beautiful OS!!

  • 1
    As someone posted before, I removed TLP power management from my system. Now the USB devices are working fine. However, the battery seems to be losing juice faster than before. Any solution to have both better power management and USB recognition is welcome. – spc Nov 17 '16 at 13:15
2

Check TLP Settings:

All TLP settings are stored in the config file /etc/default/tlp

USB

USB_AUTOSUSPEND=1

Set autosuspend mode for all USB devices upon system start or a change of power source. Input devices like mice and keyboards are exluded by default (see USB_DRIVER_BLACKLIST below). Possible values:

1 – enable 0 – disable

Note: TLP activates USB autosuspend independent of the power source, i.e. on battery and AC.

USB_BLACKLIST="1111:2222 3333:4444"

Exclude USB device IDs from autosuspend mode. Useful for devices having difficulties in waking up from autosuspend. Use tlp-stat -u to determine IDs. Multiple IDs are separated with blanks.

Hint: all input devices (driver "usbhid") get excluded by default. It's therefore unnecessary to put them on the USB_BLACKLIST. To circumvent the default for certain devices enter the IDs into USB_WHITELIST.

Note: because of conflicts with udevd v221 (and higher) the parameter USB_DRIVER_BLACKLIST had to be removed with TLP version 0.8. Enter the device IDs to be excluded into USB_BLACKLIST instead.

USB_BLACKLIST_WWAN=1

Exclude builtin WWAN devices from autosuspend mode:

0 – do not exclude 1 – exclude

Note: this feature is implemented by an internal blacklist currently matching cards from Qualcomm, Ericsson and Sierra. To re-enable autosuspend mode for WWAN, enter the ID into USB_WHITELIST.

USB_WHITELIST="5555:6666 7777:8888"

Re-enable autosuspend mode for USB device IDs already excluded by any of the lists above (whitelist always wins). Use tlp-stat -u to determine IDs. Multiple IDs are separated with blanks.

USB_AUTOSUSPEND_DISABLE_ON_SHUTDOWN=1

Disables USB autosuspend mode upon system shutdown. This is intended as a workaround if suspended USB devices disturb the shutdown process.

Extract from: http://linrunner.de/en/tlp/docs/tlp-configuration.html

Note: It's advisable to read the full article.

  • Thanks Marin for your comment about TLP settings. After Disabling the USB_AUTOSUSPEND setting my devices are working fine. – spc Nov 20 '16 at 6:36
2

Disabling USB autosuspend completely – as described in the previous answer – will increase power consumption considerably.

I finer approach would be to isolate the offending USB device by blacklisting the devices one by one:

USB_BLACKLIST="1111:2222"

and apply the new setting by:

sudo tlp usb

Refer to TLP Troubleshooting for background on the subject.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.