2

In Elementary OS 0.4 Loki, the default behavior is to disable the touchpad while typing. However, this is undesired, especially while playing games. I want to be able to type and use the touchpad at the same time.

I checked the Settings app, and found nothing to disable this undesired functionality.

How do I enable the touchpad while typing?

3

TLDR You can enable touchpad (that is disable auto-disable) with xinput set-prop DEVICE PROP 0 where you can check for your device ID and prop ID with xinput and xinput get-props DEVICE respectively.

Let's explain this a little bit: there is a new interface to do this in elementary OS 0.4 Loki xinput. In a terminal window you should look for your touchpad device:

user@machine:~$  xinput
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  
⎜   ↳ SynPS/2 Synaptics TouchPad                id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
⋮

In my case the device id is 14, so now you can get its properties

user@machine:~$ xinput list-props 14
Device 'SynPS/2 Synaptics TouchPad':
    Device Enabled (154):   1
⋮
    libinput Disable While Typing Enabled (314):    1
    libinput Disable While Typing Enabled Default (315):    1
⋮

The prop ID is 314 (and it is set to 1 that is, auto-disable is turned on) so now we can set disable this feature:

user@machine:~$ xinput set-prop 14 314 0
  • Very helpful, and explained very well! This ought to be in the settings app. – acer Nov 17 '16 at 22:53
1

If you have a Synaptic Touchpad with synclient installed you can use :

synclient TouchpadOff=0

0 = enabled 1 = disabled 2 = disabled while typing

source : https://doc.ubuntu-fr.org/touchpad#activerdesactiver_le_pave_tactile (french)

  • This might not work under elementary 0.4 Loki – lemonslice Nov 17 '16 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.