Since I'm a rookie, I don't know if it's because something I did but my top bar/wingpanel disappeared. When I type wingpanel on terminal, I get following text;

(wingpanel:2526): Gtk-WARNING **: Theme parsing error: gtk.css:1:69: Not using units is deprecated. Assuming 'px'.

(wingpanel:2526): Gtk-WARNING **: Theme parsing error: gtk.css:1:71: Not using units is deprecated. Assuming 'px'.
[INFO 19:09:15.441220] Application.vala:155: Sistem Paneli version: 2.0.1
[INFO 19:09:15.441255] Application.vala:157: Kernel version: 4.4.0-47-generic
[FATAL 19:09:15.496907] wingpanel_widgets_overlay_icon_set_main_icon_name: assertion 'self != NULL' failed
[FATAL 19:09:15.497230] wingpanel_widgets_overlay_icon_set_main_icon_name: assertion 'self != NULL' failed
[16:09:15.574393 GLib-GIO-Critical] g_file_get_child: assertion 'G_IS_FILE (file)' failed
[16:09:15.574414 GLib-GIO-Critical] g_file_query_exists: assertion 'G_IS_FILE(file)' failed
[16:09:15.574417 GLib-GIO-Critical] g_file_get_child: assertion 'G_IS_FILE (file)' failed
[16:09:15.574420 GLib-GIO-Critical] g_file_query_exists: assertion 'G_IS_FILE(file)' failed
[16:09:15.574424 Critical] gee_abstract_collection_get_size: assertion 'self != NULL' failed
[16:09:15.574430 Warning] Theme.vala:508: Currently selected gtk+ theme 'elementary' does not provide a dock theme, fallback to the built-in defaults!
[16:09:15.847607 GLib-Critical] g_hash_table_get_keys: assertion 'hash_table != NULL' failed
[16:09:15.862371 GLib-GIO-Critical] g_app_info_get_name: assertion 'G_IS_APP_INFO (appinfo)' failed
[16:09:15.862801 GLib-GIO-Critical] g_app_info_get_id: assertion 'G_IS_APP_INFO (appinfo)' failed
Segmentation fault (core dumped)

I've searched everywhere, tried everything I found, but useless. And I don't know how to fallback to the built-in defaults.

Hope someone can help me.
Thank you!

4 Answers 4


OPTION 1: open a terminal window from the dock (plank) and start wingpanel with wingpanel &. The & at the end allows the process to keep running when the terminal is closed.

OPTION 2: if you cannot open a terminal window go to tty6 (or 1-5) by typing Ctrl+Alt+F6 and loging with your username and password, then type DISPLAY=:0 wingpanel & and go back to your GUI (tty7: Ctrl+Alt+F7).

If ps -ef | grep wingpanel is showing multiple wingpanel processes running, you may want to stop them all before restarting wingpanel with the beforementioned options: killall wingpanel.


do you have a logitech wireless mouse or keyboard?

if so, Does unplugging the wireless receiver bring back the wingpanel?

If yes, Then you need to uninstall the wingpanel with:

sudo apt-get remove wingpanel-indicator-power

Anyone having this issue, I solved the problem with resetting of desktop configurations to do defaults as it said in the warning. To do so, run the following in the terminal;

cd $HOME cd .config rm -R *

and then to reboot your system to changes take effect, simply run this;


This will solve the problem and the wingpanel will come back. Thank you everyone!


I had the same issue - wingpanel suddenly disappeared.

Did a "ps -ef | grep wingpanel" in terminal and realized wingpanel wasn't running.

Restarted wingpanel process by typing "wingpanel" in terminal and wingpanel reappeared. That's it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.