1

When I first installed eOS the boot up was 'silent' ie no screen activity until the log-in screen was reached.

Now it gives a verbose list of everything that's being loaded which is not a serious issue but somewhat annoying. I guess I may have altered something that started this. Can anyone tell me how to stop this?

PS: Having dug deeper and tried different GRUB settings, it isn't showing a full verbose listing, just a list of the services starting. I'd still like to switch that off if possible.

2

I ended up re-installing eOS and rebuilding my system. I did so carefully and found out what had caused the verbose boot. It started when I installed the Nvidia binary driver v340.98. Having switched back to the Nouveau driver the verbose boot stopped and I was back to the eOS logo and a silent boot.

1

You probably installed a proprietary or updated graphics driver. Use Scratch with sudo and edit the /etc/default/grub file and under the #GRUB_GFXMODE=640x480 line add:

GRUB_GFXPAYLOAD_LINUX=auto

This will re-enable the graphics splash screen that completely covers up what's being loaded. After you quit out of Scratch, don't forget to run update-grub with sudo before rebooting.

0

Have you tried customize the GRUB?

sudo nano /etc/default/grub

Remove below values

GRUB_CMDLINE_LINUX_DEFAULT=""

Then update the GRUB

sudo update-grub

sudo reboot

Hope it helps.

  • Thanks for the response. If I remove the value I get a full verbose boot-up listing everything that's being loaded etc. If I use 'quite splash' I just get the list of services being loaded. I didn't originally have this and I think I must have don't something to initiate it, but don't know what. – Ian Haynes Nov 10 '16 at 15:07
  • Have you tried checking your BIOS settings? – Jorge R. Marín Nov 10 '16 at 16:31
  • I've just compared the Grub file for another machine I have running eOS that doesn't show the verbose boot. Checking line by line the only differences are the references to the machine identity, reference to msdos5 on one and msdos6 on the other and a slightly later version of Linux on the one that boots verbosely. – Ian Haynes Nov 19 '16 at 18:35
  • I will check BIOS settings but nothing was changed from before it went 'verbose'. – Ian Haynes Nov 19 '16 at 18:36
  • I ended up re-installing eOS and rebuilding my system. I did so carefully and found out what had caused the verbose boot. It started when I installed the Nvidia binary driver v340.98. Having switched back to the Nouveau driver the verbose boot stopped and I was back to the eOS logo and a silent boot. – Ian Haynes Dec 2 '16 at 12:53
0

it sounds to me like you are starting a different line item in grub that does not have quiet on it. suggestion ... when you are booting ... hold down the right shift key This should bring up a grub menu are you pointed at the topmost entry? you can edit (temporarily) an entry by hitting 'e' the quiet should be on the line with /vmlinuz

if you are not pointint to the top entry ... up arrow to that and hiut 'e' to see whats there ... and see if quiet is on the line there if so just boot that entry and you should be fine.

  • sorry for the typos ... just noticed them – George Barbaz Nov 10 '16 at 18:52
  • Some editing would be nice. ;-) – Jorge R. Marín Nov 12 '16 at 16:51
  • Yes the 'quiet' is on the line with /vmlinuz . Any other suggestions? – Ian Haynes Nov 18 '16 at 16:46
0

I played with this for a while. After installing Loki and setting it up with everything I needed (including nVidia driver and powertop, both of wich are a constant source of messages), here's my /etc/default/grub:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian GRUB_CMDLINE_LINUX_DEFAULT="quiet splash loglevel=0 rd.systemd.show_status=auto rd.udev.log-priority=0 vt.global_cursor_default=0"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the commandvbeinfo'
GRUB_GFXMODE=1920x1080

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

#GRUB_THEME=/boot/grub/themes/Radiano/theme.txt

Setting vt.global_cursor=0 will hide the blinking cursor.
Make sure to set GRUB_GFXMODE to your resolution values. EDIT: Works best with EFI enabled.

The result: elementary logo all the way to the desktop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.