0

My wifi keep turning off after 5 seconds

First time first, i cant activate nor deactivate the wifi by Fn + F2 (Asus laptop problem, same old with Freya) usually i did connecting wifi by sleeping and unsleep the laptop, and voila the wifi connected.

I did the sudo rfkill unblock all && rfkill list all So here is my rfkill list all result

0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: asus-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no

this is my lshw -C network result

  *-network DISABLED      
   description: Wireless interface
   product: RT5390 Wireless 802.11n 1T/1R PCIe
   vendor: Ralink corp.
   physical id: 0
   bus info: pci@0000:01:00.0
   logical name: wlp1s0
   version: 00
   serial: 08:3e:8e:3f:5d:a2
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=rt2800pci driverversion=4.4.0-36-generic firmware=0.34 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
   resources: irq:16 memory:fea00000-fea0ffff


 *-network
   description: Ethernet interface
   product: AR8161 Gigabit Ethernet
   vendor: Qualcomm Atheros
   physical id: 0
   bus info: pci@0000:02:00.0
   logical name: enp2s0
   version: 10
   serial: 08:60:6e:98:2a:63
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=alx latency=0 link=no multicast=yes port=twisted pair
   resources: irq:32 memory:fe900000-fe93ffff ioport:e000(size=128)


 *-network
   description: Ethernet interface
   physical id: 1
   logical name: enp0s16f0u2
   serial: 82:1d:5c:dd:6f:bb
   capabilities: ethernet physical
   configuration: broadcast=yes driver=rndis_host driverversion=22-Aug-2005 firmware=RNDIS device ip=192.168.42.145 link=yes multicast=yes
1

You seem to be affected by a bug described here. There is a workaround, but it doesn't fix the fn+f2 issue. See the link for full details, but here is a quick run down of what you should do.

run:

lspci -nnk | grep -A2 0280

This will show if you have a kernel driver in use and what it is called. You're looking for something like Kernel driver in use:ath9k.

Now run

lsmod | grep -e ath9k -e asus

Replace ath9k with your driver's name. This should show that the driver is loaded and show if asus_nb_wmi driver is being used. Assuming that asus_nd_wmi is being used run the following command and reboot.

echo "options asus_nb_wmi wapf=4" | sudo tee /etc/modprobe.d/asus_nb_wmi.conf

Every boot will force asus_nb_wmi to use wapf=4, which is reported to fix the hardblock issue you have.

  • Thank you dude!, but i got another issue, why my WiFi signal strength so low, even if i got my router beside me.. – 4lcatrust Nov 10 '16 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.