Good night, people.

Yesterday I was messing around to install elementary OS Freya and dualbooting with Windows 8.1. Before installing elementary OS I had Ubuntu 14.04 and W8.1 side by side perfectly, but wanted to try something else. At this point I had tried to install elementary OS twice. Here's what I did:

The first time:

Created a bootable USB with Rufus, everything working OK, selected option to "Erase Ubuntu and install elementary". Installed flawlessly (I want to believe), and gave me the final message asking to restart in order to enjoy elementary. Got a black screen for more than 2 hours. Finally I shut laptop down.

The second time:

Did the same, but instead of installing over the previous installation, I decided to manually configure the partitions. Deleted all partitions exceptuating Windows and a ~350 MB partition (the only ones left by a fresh Windows 8.1 installation). From the remaining free space I assigned 100 GB to elementary OS logical partition, ext4, mount point /; and took 6 GB for swap area. The bootloader was placed at /dev/sda wich is the default. No error installation, then the final message asking to restart. I restarted and got the same black screen. Shut the computer down and started again. Selected elementary OS option form GRUB and got the black screen again.

A strange thing is that GRUB only appears until you select Windows Bootloader. After booting into Windows, GRUB won't show up again.

Also wanted to create a recovery drive for Windows in order to completely erase Linux and try again but gave me an error message.

I attach the partitions according to AOMEI and Disk Management and the Recovery Drive error.

What could have gone wrong or could I have done wrong? Is there another way to create a rovery drive? AOMEI has something to create a drive to boot Windows but I'm not sure if it could help.

The screenshots: https://goo.gl/8HPmOK

Thanks in advance guys, I hope I was clear and detailed enough.

4 Answers 4


Try adding nomodeset to the boot. Here's how to do it:

  1. Press and hold the Shift button which will show you a GRUB screen containing a list of kernels and recovery options.


  1. Press e to edit the appropriate kernel.


  1. Add the word nomodeset before the words with quiet splash.

  2. Press Crtl+X to boot.

NOTE: This will only add the nomodeset temporarily.

Source: How do I set 'nomodeset' after I've already installed Ubuntu?

  • 2
    The link you provided is great in terms of information, but we want the information to be on StackExchange to avoid dead links and provide the essential information on the very question. Please elaborate on how the issue can be resolved with more detailed instructions on how to set the boot option, thank you very much!
    – embik
    Commented Jul 31, 2015 at 9:41

Now this post can be marked as solved.

tuxtux's answer was pretty useful, but what I did before was just plug the elementary OS stick and boot it.

Opened the terminal and used locate *grub to look for the grub folder, and found out that the folder didn't exist. Just found the grub-update folder. So, I just ran sudo update-grub. Now the computer boots into grub and doesn't skip to Windows.

Then I just added nomodeset as tuxtux suggested.

Thanks a lot guys, now I can enjoy the beauty of elementary :)

  • You can mark it as solved (= accepted answer) by yourself by clicking the checkmark under the most appropriate answer (below the downvote button) :) "How does accepting an answer work?"
    – quassy
    Commented Aug 2, 2015 at 19:52
  • And if tuxtux answer helped you out at least upvoted it. It's a "stacky" way of saying "thank you, for taking your time to help me" Commented Aug 3, 2015 at 4:06

Windows 8.1 is installed in EFI mode (I am convinst), that is, you have to start the stick in the EFI mode, and then install the EFI mode. Just look at "wiki.ubuntuusers.de/EFI_Installieren".

  • Dudes, the problem is that grub is not appearing anymore. It seems like during the startup with UEFI mode, it skips to Windows. If I use CSM boot mode, it goes directly to grub rescue> Commented Aug 1, 2015 at 6:25
  • did you follow the instructions from the link i posted. There are notes , first of all, you have to start your stick in efi-mode. Use the terminal an show what "sudo efibootmgr -v" delivers. A "sudo parted -l" is always a good idea Commented Aug 1, 2015 at 14:14

Try to enter in rescue mode and run the Boot-Repair tool.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.