"Failed to request VPN secrets #3: No agents were available for this request"

I tried reinstalling openvpn and network manager, and tried different ovpn profiles and made sure I entered the correct login information...

  • Try sudo apt install --reinstall network-manager-gnome. Log out and back in, or reboot. This should create an /etc/xdg/autostart/nm-applet.desktop that will autostart the necessary service for this. See Carlo's answer below, and this Bugzilla bug.
    – Kevin E
    Nov 11, 2023 at 3:20

3 Answers 3


Finally got the VPN working after finding the answer in the following link:


The network manager somehow uses nm-applet (which does not run by default) to access the VPN secrets.

You can add nm-applet in the System Settings > Applications > Startup by adding the custom command /usr/bin/nm-applet

  • If you want to run this now (ie without relogging in or rebooting) simply run /usr/bin/nm-applet > /dev/null 2>&1 & from a shell. If you run it as it is, you'll get no end of bitching from Gtk. You can kill it as soon as you've connected to your VPN.
    – rolandw
    Jun 27, 2019 at 17:40
  • Turns out I had "deleted" nm-applet from my elementaryOS ApplicationsStartup configuration. This creates a ~/.config/autostart/nm-applet.deskop with the key NotShowIn=KDE;GNOME;Pantheon. I probably thought "hmm, probably don't need that." Yeah, no. It is what makes the openconnect VPN able to prompt you for your password. Delete this file, log out and back in, and the applet will autostart by virtue of there being a /etc/xdg/autostart/nm-applet.desktop that comes with the network-manager-gnome package.
    – Kevin E
    Nov 11, 2023 at 3:13

openvpn seems to have some troubles getting the things right, I managed to log in to vpn service with pptp protocol ( seems it's doing the right setup )


I always install software-properties-gtk after installing Elementary OS and encounter this issue everytime with PPTP.

After reinstalling ElementaryOS the last time, I decided to skip installing software-properties-gtk and never encountered the issue since. Even after multiple restarts.

I think the software-properties-gtk package breaks the VPN configuration tool since I was able to connect to a VPN (PPTP) using a fresh live USB of Elementary OS without issues. The software-properties-gtk has been removed from Ubuntu 16.04 and might be causing issues with the newer packages of Ubuntu.

  • Nevermind. My VPN suddenly stopped working again. Nov 23, 2016 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.