2

Noob here.

Just installed elementaryOS for the first time. Yay!

Tried to fire up a text editor. No go. Vim shows as being installed in the App Center. But it does not show up under the "Applications" menu, and launching it from the command line says it can't be found.

I uninstalled it and installed it again. Same deal.

I uninstalled and resinstalled the app center. Same deal.

I did an "apt update" and reboot. Again, no vim.

Poked around in the file system looking at the usual bin directories. No vim.

What am I missing?

2

Steps to resolve this issue:

  1. ignore AppCenter. Install vim-gnome from the command line.
  2. install "Menu Editor" from the AppCenter. The Menu Editor icon will show up Slingshot (the "Applications" menu).
  3. Fire up the Menu Editor and select GVim.
  4. Enable the "Hide from menus" switch. Exit the Menu Editor and Save changes.
  5. Fire up Menu Editor again. Select GVim again, and this time deselect the "Hide from menus" switch.
  6. Exit Menu Editor, saving changes.

GVim now appears in the Applications folder.

  • 1
    You can accept your own answer so that it does not show unanswered any more. – lemonslice Nov 12 '16 at 10:07
1

You can run Vim with vi from the command line.

However, there is no icon in the menu indeed, not even after installing the gvim package… so you might want to file a bug report.

  • I have filed a bug report. However, this seems to be an issue for me for several different applications (eg Gazebo also doesn't appear in the Applications menu when installed from the AppCenter). Also: even after installing vim from the app center, I can't run it (or vi) from the command line. I have to sudo apt-get install it before I can run it. – GlenH Nov 2 '16 at 15:32
1

use "vim.tiny" as vim execute command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.