I downloaded this game, and it simply does nothing when I try to run it. No error, nothing.

I tried to see what was wrong by running it with the command "ldd" and it gave me this:

wayne@wayne-iMac:~$ ldd /home/wayne/Downloads/MaximumVelocityLinux/MaximumVelocity.x86 linux-gate.so.1 => (0xf76e3000) libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf76bf000) libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf76a3000) librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf7699000) libGLU.so.1 => /usr/lib/i386-linux-gnu/libGLU.so.1 (0xf7626000) libGL.so.1 => /usr/lib/i386-linux-gnu/mesa/libGL.so.1 (0xf7594000) libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf7460000) libXext.so.6 => /usr/lib/i386-linux-gnu/libXext.so.6 (0xf744d000) libXcursor.so.1 => /usr/lib/i386-linux-gnu/libXcursor.so.1 (0xf7441000) libXrandr.so.2 => /usr/lib/i386-linux-gnu/libXrandr.so.2 (0xf7436000) libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf73f0000) libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf73d3000) libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7225000) /lib/ld-linux.so.2 (0xf76e6000) libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xf713c000) libexpat.so.1 => /lib/i386-linux-gnu/libexpat.so.1 (0xf7113000) libglapi.so.0 => /usr/lib/i386-linux-gnu/libglapi.so.0 (0xf70fa000) libXdamage.so.1 => /usr/lib/i386-linux-gnu/libXdamage.so.1 (0xf70f6000) libXfixes.so.3 => /usr/lib/i386-linux-gnu/libXfixes.so.3 (0xf70f0000) libX11-xcb.so.1 => /usr/lib/i386-linux-gnu/libX11-xcb.so.1 (0xf70ec000) libxcb-glx.so.0 => /usr/lib/i386-linux-gnu/libxcb-glx.so.0 (0xf70d4000) libxcb-dri2.so.0 => /usr/lib/i386-linux-gnu/libxcb-dri2.so.0 (0xf70ce000) libxcb-dri3.so.0 => /usr/lib/i386-linux-gnu/libxcb-dri3.so.0 (0xf70ca000) libxcb-present.so.0 => /usr/lib/i386-linux-gnu/libxcb-present.so.0 (0xf70c6000) libxcb-sync.so.1 => /usr/lib/i386-linux-gnu/libxcb-sync.so.1 (0xf70be000) libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf709c000) libxshmfence.so.1 => /usr/lib/i386-linux-gnu/libxshmfence.so.1 (0xf7099000) libXxf86vm.so.1 => /usr/lib/i386-linux-gnu/libXxf86vm.so.1 (0xf7093000) libdrm.so.2 => /usr/lib/i386-linux-gnu/libdrm.so.2 (0xf7084000) libXrender.so.1 => /usr/lib/i386-linux-gnu/libXrender.so.1 (0xf7078000) libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf7074000) libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf706d000)

I installed all the libraries but it still doesn't run.

iMac (21.5-inch, Mid 2011)

Processor 2.5 GHz Intel Core i5

Graphics AMD Radeon HD 6750M 512 MB

Memory 4 GB 1333 MHz DDR3

  • What does sudo apt-get install libx11-6 return? Adding :i386 (sudo apt-get install libx11-6:i386) installs the x86 variant. Jul 30, 2015 at 10:24
  • wayne@wayne-iMac:~$ sudo apt-get install libx11-6 [sudo] password for wayne: Reading package lists... Done Building dependency tree Reading state information... Done libx11-6 is already the newest version. libx11-6 set to manually installed. The following packages were automatically installed and are no longer required: gtk3-engines-unico libtimezonemap1 Use 'apt-get autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 46 not upgraded. Jul 30, 2015 at 18:59
  • Even after doing sudo apt-get install libx11-6:i386 it doesn't work. Jul 30, 2015 at 22:14
  • And it still shows libX11.so.6 => not found? Jul 30, 2015 at 22:42
  • These are the only ones that say, not found. libGLU.so.1 => not found, libGL.so.1 => not found, libXext.so.6 => not found, libXcursor.so.1 => not found, libXrandr.so.2 => not found, The rest doesn't fit here. Jul 31, 2015 at 0:05

1 Answer 1


You need to install the relevant libraries in 32-bit.

For example, "sudo apt-get install libglu1-mesa:i386" should get rid of the "libGLU.so.1 => not found".

With some effort I'm sure you can find the packages for the other libraries.

  • Even after installing all the libraries it doesn't work. Aug 13, 2015 at 23:46
  • has anything changed? I assume you're running in from the command line - what prints out there? Aug 15, 2015 at 7:48
  • I posted it above. Aug 17, 2015 at 0:41
  • Not from ldd, when you actually try to run the game Aug 17, 2015 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.