2

I'm using a touch laptop, I want to disable auto rotate, can not find an option that dies that, can you guide me please or provide a terminal line for it? Thanks for the Awesome OS.

  • I have the same issue with Loki on a Yoga 2 Pro. I submitted a bug request to see if they can adjust the sensitivity or allow one to turn off the feature. – James Grant Dec 6 '16 at 17:38
3

I resolved this issue (Yoga 2) by disabling rotation via three gsetting commands:

gsettings set org.gnome.settings-daemon.peripherals.touchscreen orientation-lock true

gsettings set com.ubuntu.touch.system orientation-lock 'PrimaryOrientation'

gsettings set com.ubuntu.touch.system rotation-lock true

You can check if those settings have changed with command:

gsettings list-recursively | grep '\-lock' | grep true

Then finally:

reboot

When the system boots back into elementary you should be rotate free.

| improve this answer | |
  • I have tried to copy and paste onto the terminal but display flipped again.This is a beatiful and workable system,but display orientation is not a good idea on a non android device.I will be back when this bug is fixed and display orientation is removed,but thanks alot – bob Mar 12 '19 at 17:44
0

You can disable the rotation sensor with the following commands:

sudo systemctl stop iio-sensor-proxy.service

sudo systemctl disable iio-sensor-proxy.service

or

sudo apt-get remove iio-sensor-proxy

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.