1

I followed these instructions to install gcalcli (a google calendar commandline interface):

https://installion.co.uk/ubuntu/xenial/universe/g/gcalcli/install/index.html

but get this error when I try to run it after install:

Traceback (most recent call last): File "/usr/local/bin/gcalcli", line 4, in import('pkg_resources').run_script('gcalcli==3.4.0', 'gcalcli') File "/usr/lib/python2.7/dist-packages/pkg_resources/init.py", line 2927, in @_call_aside File "/usr/lib/python2.7/dist-packages/pkg_resources/init.py", line 2913, in _call_aside f(*args, **kwargs) File "/usr/lib/python2.7/dist-packages/pkg_resources/init.py", line 2940, in _initialize_master_working_set working_set = WorkingSet._build_master() File "/usr/lib/python2.7/dist-packages/pkg_resources/init.py", line 637, in _build_master return cls._build_from_requirements(requires) File "/usr/lib/python2.7/dist-packages/pkg_resources/init.py", line 650, in _build_from_requirements dists = ws.resolve(reqs, Environment()) File "/usr/lib/python2.7/dist-packages/pkg_resources/init.py", line 834, in resolve raise VersionConflict(dist, req).with_context(dependent_req) pkg_resources.ContextualVersionConflict: (oauth2client 1.4.12 (/usr/local/lib/python2.7/dist-packages/oauth2client-1.4.12-py2.7.egg), Requirement.parse('oauth2client<5.0.0dev,>=1.5.0'), set(['google-api-python-client']))

Has anyone figured this out? I've tried installing the required oauth2client

https://pypi.python.org/pypi/oauth2client/4.0.0

... but that doesn't help

Any suggestions?

  • Does an error message appear before the traceback? – Ryan DeBeasi Dec 15 '16 at 14:52
  • I'm pretty sure that was the entire output, but now I've moved on to Fedora 25 and gcalcli is working fine there. Thanks :) – D Parker Dec 16 '16 at 16:22
2

Under elementary OS 0.4 Loki you can simply install gcalcli with

sudo apt install gcalcli

Not the answer you're looking for? Browse other questions tagged or ask your own question.