I seem unable to open/run LibreOffice (in the latest version of Elementary). I installed it via the AppCenter. If I click on it from the Applications menu, the icon appears in the dock briefly, but no windows open. Right-clicking on the dock icon and selecting an option (e.g., "Writer") does nothing. Eventually, the icon disappears.

How can I run LibreOffice? It is critical that I be able to properly read and write Open Document Format, as well as Microsoft Office-type files.

Thank you!

3 Answers 3


I also had this problem installing LibreOffice from appcenter. Solved uninstalling it with appcenter and installing (also with appcenter) separatedly the Libreoffice applications (writer, spreadsheets...). This installs also LibreOfice environment.

Update: I understand that you want to install Libreoffice from app center that's why I gave you an "appcenter solution" that worked for me. Obviouly, you can always install Libreoffice using terminal issuing:

sudo apt update

sudo apt install libreoffice

  • That same solution worked for me too. Install the apps individually. However, I noticed that the version installed is 5.1, while the current version is 5.2 (and there's a 5.3 coming soon). It's not clear to me how we update to newer versions in elementary. So far the only updates I've gotten in the app center are for the core apps that come with elementary (mail, calendar, etc.), not apps I have downloaded through the app center.
    – brad
    Commented Jan 23, 2017 at 21:48
  • 1
    @brad appcenter apps that aren't in the elementary's repository will update according to their source, usually Ubuntu Xenial.
    – Lewis Goddard
    Commented Jan 24, 2017 at 18:19

The same problem happened to me, the problem was that my computer didn't "know" that Libre Office was installed, so when I installed it from the terminal it worked again


I too had the same problem loading the entire Libre Office suite from the app center. After uninstalling the suite and reinstalling the components separately from the app center, I was able to get all of the components working properly. Thanks for the suggestion and I hope this helps.

Not the answer you're looking for? Browse other questions tagged or ask your own question.