0

I'm updating the OS on a laptop. The problem is built-in display doesn't work.

After booting Loki from USB I see a screen with wallpaper, no panel, no options. Right clicking the desktop has no effect. No shortcut helped me open anything.

What I need: - Open settings on second monitor and change display config, OR - Disable built-in monitor and set HDMI as primary

What I tried: - Xrandr: tried lots of things but they all produce "Can't open display"

0

I solved the problem and achieved HDMI as primary. It took me days of googling to finally find the answer.

To set HDMI as primary monitor: 1) Ctrl + alt + f1. If you are running eOS from the USB or live cd, user is:elementary; there's no password, just press enter.

2) type: export DISPLAY=:0, enter.

3) run xrandr --output HDMI1 --primary

Now you can use your distro settings to adjust display settings to fit your needs.

Hope it helps ppl.

0

Open system settings, click displays, you should see two boxes of different colours (I get blue and orange).

Each box represents a display, and has two buttons - a star and a gear.

The gear gives you a limited number of settings, but the star is the one you want - click it and it will make that display your 'favourite', and both the Wingpanel and Plank dock will appear on that display only.

Sometimes your settings will be forgotten, but it is not hard to change them.

Also there is a switch labeled 'Mirror Display:' this one does what it says on the tin, so if you can't change your primary display, this one is for you.

  • As I mentioned, my built-in screen was not working. The second monitor is set to extend primary by default, and it doesn't show panel, or anything else, so I was unable to change any configurations using system settings. Your approach is obvious but it doesn't fit the problem I was facing. – Flying Arrow Oct 24 '16 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.