5

In the power settings there is no option to perform the shutdown action when a I press the power button. I only see the options to suspend and hibernate or do nothing.

1

You have to edit logind.conf in /etc/systemd, and change the line as shown below (remember to unhash it):

HandlePowerKey=poweroff

Now I'm on Manjaro, so I can't confirm if it works, but it should.

  • I just tried this and it does not seem to work ... still does a sleep ... mind you ... I am not on a laptop so that could cause a difference – George Barbaz Oct 26 '16 at 8:10
  • There is the option, I tried that but it does not work. – Mateus Oct 27 '16 at 17:50
1

Do this:

Open terminal. Type: sudo apt-get install dconf-tools

Hit Enter

After installing dconf-tools, on screen (desktop), click on Applications (top left of the screen), then find and click on dconf Editor (normally the logo is a Magnifying glass with a checked red box)

In dconf Editor, go to: org > gnome > settings-daemon > plugins > power

Click on the value of button-power and choose shutdown

0

You could put this command in the terminal:

gsettings set org.gnome.settings-daemon.plugins.power power-button-action shutdown

It should force your dconf to be set for shutdown when power button is pressed.

  • also tries this ...however – George Barbaz Oct 26 '16 at 8:15
  • I guess they have removed the shutdown functionality for the power button. You should notify the bug tracker of elementary, they might tell you another way or simply add this feature for the next update. – alexger12 Oct 26 '16 at 13:48
  • 1
    The command does not work, I also tried the dconf-editor, the option shutdown does not appear. – Mateus Oct 27 '16 at 17:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.