1

Sometimes, the desktop environment of elementary OS Loki failed to start when i've entered my password in LightDM.

Do you have any tips for me ?

Thx for read this post.

  • You should read the last lines of file /var/log/syslog to see if you can find anything strange there. You can do it from the GUI or tail /var/log/syslog. Opening a terminal with Ctrl+Alt+F2 (before entering your password in GUI) logging in terminal and using top can also help. Afterwards come back to GUI with CTRL+ALT+F7 enter your password in GUI and come back again to terminal with CTRL+ALT+F2 to see if you can determine the cause of this problem. You can alternate between GUI and terminal. NOTE: I use F2 but you can use F3, F4... – Jorge R. Marín Oct 22 '16 at 23:17
1

This technique is work for me:

  1. Open "Files" application as root
  2. Browse folder: /etc/xdg/autostart/
  3. Rename file: at-spi-dbus-bus.desktop to at-spi-dbus-bus.disabled
  4. Restart

I can confirm that renaming /etc/xdg/autostart/at-spi-dbus-bus.desktop to /etc/xdg/autostart/at-spi-dbus-bus.disabled fixed the issue for me as well.

  • 1
    It might be easier to provide a single console command which can do this in one go instead of opening Files as root (which is not terribly safe). – Mike Wild Jan 26 '17 at 22:56
1

I'm curious if your desktop failed to start, or maybe it hung for a long time. (long time = 2-3 or more minutes)

On 3 different installs, I've seen this problem happen after installing the latest system updates.

On all of them, I solved the problem by going to terminal and running this:

sudo mv /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.disabled
0

You should pay attention to this:

https://bugs.launchpad.net/elementaryos/+bug/1596377

It's a know bug, isn't solved yet but its on work :D

Not the answer you're looking for? Browse other questions tagged or ask your own question.