0

Have tried everything. VLC no longer opens via GUI. Once I did get the dvd to play in VLC by opening it from terminal. I can only open from terminal now. This is what it says:

gabriel@gabriel-SVE1511RFXB:~$ vlc
VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
[0000000000732148] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Gtk-Message: Failed to load module "pantheon-filechooser-module"

(vlc:20300): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(vlc:20300): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(vlc:20300): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(vlc:20300): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
libdvdnav: Using dvdnav version 5.0.3
libdvdread: Could not open /dev/sr0 with libdvdcss.
libdvdread: Can't open /dev/sr0 for reading
libdvdnav: vm: failed to open/read the DVD
libdvdread: Could not open /dev/sr0 with libdvdcss.
libdvdread: Can't open /dev/sr0 for reading
[00007f53c4000e98] dvdread demux error: DVDRead cannot open source: /dev/sr0
[00007f53dc0009b8] core input error: open of `dvd:///dev/sr0' failed
  • To avoid closing this as a bug, can you give more information? What happened when you tried the default Videos app (audience)? Does it work with other operating systems on your computer (is the issue the drive or the software)? What other apps have you tried? Does the region of the disc match that of the drive? – wolf Oct 19 '16 at 4:53
  • When I open the videos app, select play from disk, it opens like a gray screen in the video window. Sometimes it shows the disc title in the title bar. – GS94 Oct 20 '16 at 17:43
  • I have it dual booted and the disc does play in windows 7. I checked to make sure the region for the drive was set to North America and I did try two different dvds, each with the same result. On only one occasion I did get the video to start in the default Video player but it was so pixelated and jerky that it was worthless anyway. Also only about two or three times had the same happen with VLC but only if I started it from the terminal. – GS94 Oct 20 '16 at 17:47
  • I'll get back to you on the other video players I tried. I did install the Ubuntu-restricted-extras, libdvdread4, libdvdnav4, libdvdcss2. – GS94 Oct 20 '16 at 17:48
1

I have had troubles with the videos app as well. You could open it by starting it from the terminal with:

audience

Then copy and paste the output of the command here to give us more info.

You could try installing libdvd-pkg which should install everything you need to play a dvd.

sudo apt-get install libdvd-pkg

You will then need to run the following afterward

sudo dpkg-reconfigure libdvd-pkg

to finish the installation.

Reference: DVD Issues in 16.04

The link also has additional suggestions you might want to try.

Here are a few things I have noticed:

  • light-locker needs to be running - I had disabled it and this causes videos to crash
  • I need to open files and mount the DVD by clicking on it before I can open it in videos
  • Sometimes videos tries to open my LRS_ESP partition (I have a multi-boot system) and play it instead of the DVD drive. Not sure why. Usually corrects if I unmount that partition then try again.
  • Ok thanks I'll give that stuff a try and let you know. I did install libdvd-pkg but I didn't know about the reconfigure. – GS94 Oct 21 '16 at 15:24
  • gabriel@gabriel-SVE1511RFXB:~$ audience [INFO 21:04:01.359451] Application.vala:155: Videos version: 0.2.0.2 [INFO 21:04:01.359514] Application.vala:157: Kernel version: 4.4.0-43-generic [FATAL 21:04:14.403621] marlin_view_chrome_basic_location_bar_real_set_display_path: assertion 'path != NULL' failed – GS94 Dec 19 '16 at 3:05
  • This is what I get when I open audience from terminal and it has only the option to play from a file now. – GS94 Dec 19 '16 at 3:06
  • also what is light locker and how do I check it? – GS94 Dec 19 '16 at 3:07
  • Light locker should be running by default. I installed a program called System Monitor from the App Center which shows all the running processes. That should tell you if it is running. – Jason Gambrel Dec 20 '16 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.