I purchased an Sapphire Radeon RX 460 card for my Loki machine, installed it and booted. I can log in fine but my machine does not detect my dual displays, one currently mirrors the other one.

I tried to install the AMDGPU-PRO drivers, got the unsupported OS error, changed all of my system information to look like a vanilla Ubuntu machine, the successfully installed the drivers.

After rebooting I get dual blackscreens except for my mouse pointer. Then I uninstalled the AMDGPU-PRO drivers and I'm back to my 1 monitor problem. I've tried installing the oibaf drivers but that didn't fix the issue.

When I check software-properties-gtk I get "no proprietary drivers in use".

lspci shows the following entry:

02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Device 67ef (rev cf)

Update 1: I've since put my nvidia card back in but I'd like to get the AMD card working if possible since it's such a newer card.

I did notice in the "additional drivers" section no drivers show up except for "intel microcode" whereas when I have the nvidia card in it shows the nouveau driver and possible Nvidia branded drivers themselves. Is this normal for AMD cards?

Update 2: Is no one using an AMD video card on Loki or Ubuntu 16.04?

Update 3: Below is xrandr --verbose output if that gives more helpful information:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1920 x 1080, current 1920 x 1080, maximum 1920 x 1080
default connected primary 1920x1080+0+0 (0x274) normal (normal) 0mm x 0mm
Identifier: 0x273
Timestamp:  73741
Subpixel:   unknown
CRTC:       0
CRTCs:      0
Transform:  1.000000 0.000000 0.000000
            0.000000 1.000000 0.000000
            0.000000 0.000000 1.000000
1920x1080 (0x274) 159.667MHz *current
    h: width  1920 start    0 end    0 total 1920 skew    0 clock  83.16KHz
    v: height 1080 start    0 end    0 total 1080           clock  77.00Hz
  • I also have an AMD Sapphire card in my Loki machine. Did exactly what you did and had to uninstall AMDGPU-PRO. Fortunately the open source drivers works with my multiple monitor setup, but I experience tearing which sucks for gaming. I'm just waiting it out until a better update is available or until AMD / the Elementary guys / Canonical comes up with a solution. Commented Oct 24, 2016 at 19:51
  • @Craven Did you have to do any unplugging and replugging of cables or switching resolutions to get both monitors recognized? Commented Oct 25, 2016 at 14:52
  • I am currently installing a brand new R460 card into a dell N series workstation running on Loki, and I have an issue with the AMD drivers too. They just won't install as apparently the xserver is too new. The AMD drivers support up to 1.10 and the loki one out of the box exceeds that number by 0.01 something. So yes, Using AMD card. The goal was to finally get rid of the Nvidia nouveau annoyance. Boy, did I succeed! Commented Feb 8, 2017 at 16:42

1 Answer 1


I also have an AMD RX 460 based card that I got a few weeks ago which I understand is not quite yet supported by Ubuntu 16.04 (and thus Loki) with the current 4.4 kernel but if you wait for just a few hours (maybe a day or two) the Ubuntu 16.04.2 update release should be out with new 4.8 kernel and Xorg stack which should get you up and running even with the built-in "amdgpu" open source driver.

FYI, I had already earlier installed the 4.8 preview kernel from the "HWE" (hardware egde) package and newer Xorg stack from the "oibaf" PPA and it's already working smooth for me, so I am looking forward to the official 16.04.2 release and subsequent Loki updates so I can remove the preview package and PPA.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.