0

always this lock message

enter image description here

sometimes appear a update alert icon on top right beside the wifi icon, but i can't update because this lock

by the way, first I ran the shell command, after this, I tried the update software

2

This could be a problem with broken dependencies. If you've added PPAs or other third-party software sources, various dependencies might be conflicting with one another.

You could try running sudo apt-get install -f, which will attempt to fix the dependencies. (Source) If that doesn't work, this Ask Ubuntu question has additional steps you could take.

All that said, now might be a good time to do a clean install of Loki, the latest version of elementary. (It looks like you're on Freya.) You'll need to do a clean install to get the latest version anyway, and setting your applications back up might be easier than trying to resolve the dependency problem.

A fresh install will get you back to the default software sources. Loki also replaces the Ubuntu software update tools with elementary's new AppCenter, which I've found to be simpler and more reliable.

  • the first one works very well. – david Oct 18 '16 at 21:20
  • I try the "install -f" , but shell suggested run "sudo dpkg --configure -a" before . then first I went with shell suggested, everything worked fine, then i ran your suggest,so lastly, i try to run the update and works, thanks lot – david Oct 18 '16 at 21:32
  • That's great - I'm so glad to hear that it worked for you! Please don't forget to mark this answer as "accepted" so that other people with the same problem can find it. Thanks! :) – Ryan DeBeasi Oct 19 '16 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.