I have Asus X555UB with dual-boot OS: Windows 10 and eOS Loki. As an Audio Device i have Intel Corporation Sunrise Point-LP HD Audio (rev 21) (or Realtek ACL256).

The problem is that microphone does not work, headphones doesn't switch automatically when plugged in and after booting into windows the sound completely vanishes even from speaker. This problem also persists in Ubuntu 16.04 LTS as well as in Elementary OS Loki. I have tried many basic solutions such as complete check of all alsamixer "mute" occurrences ,have tried to reinstall :

sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio unity-control-center
sudo alsa force-reload


pulseaudio -k

have tried alsa-tools and tried to override different devices with the help of hdajackretask. But nothing have helped. It is one of the most severe bugs i currently have. Please, give me a hint where to find a possible solution at least to fix my microphone.

  • Doublecheck "Fast Boot" option in BIOS. It must be disabled
    – vp_arth
    May 28, 2017 at 5:59

2 Answers 2


I have found solution by myself. in case of someone has the same problem - windows dualboot uses a fastboot, so after boot into windows do not restart your computer , just shutdown it. after a boot through your eOS/ubuntu , make the following entries in your terminal:

sudo apt-get update && sudo apt-get upgrade
echo options snd-hda-intel model=auto | sudo tee -a /etc/modprobe.d/alsa-base.conf

check all mutes and unmute them through

sudo alsamixer

then make

shutdown -h now

it should most definitely work.

There is only temporary solution for microphone though, it will work till you reboot your system. But you may automatize it if you wish so. Following terminal entries will fix it:

sudo hda-verb /dev/snd/hwC0D0 0x1a SET_AMP_GAIN_MUTE 0x5003
sudo hda-verb /dev/snd/hwC0D0 0x1a SET_AMP_GAIN_MUTE 0x6003
sudo hda-verb /dev/snd/hwC0D0 0x23 SET_AMP_GAIN_MUTE 0x5200
sudo hda-verb /dev/snd/hwC0D0 0x23 SET_AMP_GAIN_MUTE 0x6200
sudo hda-verb /dev/snd/hwC0D0 0x08 SET_AMP_GAIN_MUTE 0x503f
sudo hda-verb /dev/snd/hwC0D0 0x08 SET_AMP_GAIN_MUTE 0x603f
sudo hda-verb /dev/snd/hwC0D0 0x08 SET_POWER_STATE 0
sudo hda-verb /dev/snd/hwC0D0 0x1a SET_POWER_STATE 0

This solution works for all Asus X5** series with core i7 skylake internal audio with Realtec ALC256 codec.


Realtek ALC256 sound card problems have been resolved in Linux Kernel 4.12 and later.

  • You should include instructions for installing it.
    – RolandiXor
    Aug 11, 2017 at 6:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.