2

How do I fix this?

W: The repository 'cdrom://elementary OS 0.4 _Loki_ - Stable amd64 (20160921) xenial Release' does not have a Release file.
    N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
    N: See apt-secure(8) manpage for repository creation and user configuration details.
    E: Failed to fetch cdrom://elementary OS 0.4 _Loki_ - Stable amd64 (20160921)/dists/xenial/contrib/binary-amd64/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
    E: Some index files failed to download. They have been ignored, or old ones used instead.
3

Did you install cdrom://elementary OS 0.4 _Loki_ - Stable amd64 (20160921) as a repository? See if it's listed with grep ^ /etc/apt/sources.list /etc/apt/sources.list.d/*

If so, you want to remove it. If you are attempting to upgrade to Loki, you'll need to do a fresh install from boot (not an upgrade). There are installation directions on the official website.

0

I had a similar issue, except mine was "20160909" instead of 20160921. I don't know where it came from, but I fixed it by installing the "Additional Drivers" app from the AppCenter (I remembered it from Linux Mint), it has a tab called "Other Software" where you can remove/disable PPAs with a click.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.