4

The new AppCenter appears to periodically and automatically update the apt indexes which is not a problem, however, this bug means that every time it does so, packagekitd hogs CPU until I purposefully kill it.

Is there any way that I can disable the auto-update feature in AppCenter or the otherwise responsible application whilst the bug is attended to?

closed as off-topic by Hasan, lemonslice Apr 17 at 19:35

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "The Question is about a release or feature that has been significantly updated, to the point at which upgrading fixes the issue or answers the question." – Hasan, lemonslice, Hasan
If this question can be reworded to fit the rules in the help center, please edit the question.

1

Using your favorite editor open the file /etc/apt/apt.conf.d/10periodic and change:

APT::Periodic::Update-Package-Lists "1"; to APT::Periodic::Update-Package-Lists "0";

0

I am not totally sure if this will work, but have you tried editing /etc/apt/apt.conf.d/10periodic to disable the auto update of the package list?

I went the other way and actually have my server upgrade over night (except the kernel, so no reboots) but that may not be what you want.

Not the answer you're looking for? Browse other questions tagged or ask your own question.