After installing nvidia-370 drivers from official PPA, I cannot boot into my system from first try. So, basically each time I try to start my machine, after initial bios diagnostics it produces this: enter image description here

Text is mine. What I meant to say - it should have allowed me to enter password, but it doesn't. No terminals are available either.

Then, after force shutdown and reboot, I get this: enter image description here On which I successfully can enter my password and boot up the system.

So my question is - how do I fix this? The best solution would be to enable decrypting elementary using standard text-box (on first screen), but if it's not possible, I agree for console option.

  • Can you give more context on your drive setup and how/when you set up the encryption?
    – wolf
    Commented Oct 11, 2016 at 19:05
  • I setup encryption during install (whole disk encryption I presume). Drivers from here: launchpad.net/~graphics-drivers/+archive/ubuntu/ppa Nvidia 370.28
    – DmitryM
    Commented Oct 12, 2016 at 8:43

1 Answer 1


Actually, that seems like a regular problem across Linux, when people try to use NVIDIA drivers and encrypted file-system. Plymouth doesn't play well with NVIDIA.

The temporary solution is to disable splash screen during boot: sudo nano /etc/default/grub

In editor, change GRUB_CMDLINE_LINUX_DEFAULT="splash quiet" to GRUB_CMDLINE_LINUX_DEFAULT="nosplash quiet". Make the same adjustments to theGRUB_CMDLINE_LINUX if it's not empty.

And then update grub using sudo update-grub.

Hope it helps somebody.

More info:

  1. Cannot enter password to start Ubuntu

  2. passphrase input-box for encrypted disk is not shown

  3. Password not accepted graphical boot for encrypted root system

  • Going to try this now seeing I have the same issue, I will edit this comment as needed after reboot.... nope, same issue, I will check that I saved the changes correctly though. Found it: the above changes are correct with one exception, the timeout is adjusted by nvidia to a value of 5, I reset this to 0 along with the changes listed above and am now error free.
    – CyberGhosT
    Commented Oct 14, 2016 at 3:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.