2

Although the Applications Launcher is apparently supposed to take on the role of Alt-F2-like command execution as well, it does not have useful features such as tab-completion of the command, command history, etc.

Is there a way to enable Alt-F2 functionality in elementaryOS (Loki in this case)?

(The zenith-based method mentioned in this thread doesn't provide these features either.)

4

As mentioned in the other comments in that bug report thread, there are a few other options using external software, to enable full Alt-F2 functionality.

There's gmrun and synapse, both of which are available in the apt repository sources to install (sudo apt install gmrun, or sudo apt install synapse).

xfrun4 is also mentioned as part of xfce4-utils package, but that one doesn't seem to be available in the default repo sources.

gmrun is a very small download (<100kB) that produces a simple text box with tab-completion and history, no bells and whistles beyond that.

synapse tries to be more comprehensive, perhaps similar to 'Launchy' for Windows or 'Spotlight' on MacOS. It has a pretty good-looking GUI, has those core features of tab-completion and history, along with the ability to search your Images, Audio, Documents, etc. optionally. That predictably brings in allegations of being "bloated" as mentioned in the thread, though that's obviously subjective and depends on your preferences.

To enable the shortcut key:

  • for gmrun: go to System settings -> Keyboard -> Shortcuts tab, choose Custom in the left panel, click on the + button at the bottom and enter the name of the program (gmrun). Then click on the text that says Disabled next to the command name, and press Alt-F2 to assign that shortcut to it.

  • for synapse: go to System settings -> Applications -> Startup, click on the + button at the bottom and enter the name of the program (synapse), choose the Synapse program entry shown there. Then, if you wish to have the shortcut to be Alt-F2 instead of the default Ctrl-Space (which didn't reliably work for me, for some reason), start synapse manually from the terminal or Launcher, click the small circle on the top right and choose Preferences, and there change the shortcut for Activate to Alt-F2. (If the Preferences window doesn't show the actual shortcuts, right click on the window's titlebar and choose Maximize.)

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.