2

Whenever you click on one of those "Browse" or "Open" or "Save As" buttons, a small Files window will launch and you either look for a file to open up or a place to save one.

Sometimes that functionality disappears, most noticeably in Scratch but also in other applications. The relevant Open or Save button is gone and I can't even overwrite files to override the problem.

I've tried installing other file managers and set them to default but this made no difference.

2

This can be solved by overriding xsettings:

gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/DialogsUseHeader': <0>, 'Gtk/ShellShowsAppMenu': <0>, 'Gtk/DecorationLayout': <'close:menu,maximize'>}"

File chooser dialog has minimum size much bigger after running that command. This could be annoying.

Also this is duplicate of this post: gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/DialogsUseHeader': <0>, 'Gtk/ShellShowsAppMenu': <0>, 'Gtk/DecorationLayout': <'close:menu,maximize'>}"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.