0

I have encountered a weird problem with the recent version of Mozilla Firefox (49.0) on Loki. There seems to be a bug when displaying Wikipedia pages - words in italics are simply left out. See e.g. here:

enter image description here

With Google Chrome 53.0.2785.143

enter image description here

and Chromium 53.0.2785.143

enter image description here

there's no problem at all. I haven't noticed the issue on any other web page except Wikipedia.

Any ideas?!?

2
  • Weird - I pulled up the same page on my copy of Firefox 49 and the italics displayed fine. Are other websites affected? Have you installed any extra font packages or the like? Oct 8, 2016 at 22:50
  • Not that I would have noticed. I can't remember installing extra font packages either
    – deesnook
    Oct 8, 2016 at 23:47

3 Answers 3

1

Firefox

I'm unable to reproduce the error. I suggest right-clicking on the area you want to inspect and selecting "Inspect Element". Look if anything is out of the ordinary or try to toggle the CSS if you don't have the italics element showing like I do above. Page might just need a refresh.

Worst comes to worst, reinstall Firefox. It's likely something off with your configuration. If the issue recurs, it's a bug to take to Firefox's bug tracker.

5
  • Thanks wolf. I've purged and reinstalled Firefox, the problem persists. I couldn't tell by inspecting the element that anything was unusual. I'll file a bug report I guess
    – deesnook
    Oct 9, 2016 at 17:26
  • @deesnook, what about add-ons? Have you tried removing Firefox's extensions? Not sure what that blue "S" in the upper-right corner is
    – wolf
    Oct 9, 2016 at 17:44
  • the only add-on I have is NoScript (the blue S). Uninstalling didn't help :(
    – deesnook
    Oct 12, 2016 at 18:40
  • What did you have loaded in NoScript and did you try turning off those effects before uninstalling it?
    – wolf
    Oct 13, 2016 at 16:05
  • I'm not sure what you're driving at. I used NoScript with the default settings blocking scripts, but whitelisting some websites I commonly use (including Wikipedia of course). Also after purging Firefox it didn't work either, even without NoScript
    – deesnook
    Oct 23, 2016 at 10:45
0

Try to uninstall extensions and reset firefox. If the problem persists, try to reinstall it

1
  • the only add-on I have is NoScript. Uninstalling didn't help :( reinstall either
    – deesnook
    Oct 12, 2016 at 18:40
0

Same symptoms here, running Ubuntu. Turns out the italic version of the font was not installed properly.

In Ubuntu, reinstalling the package fonts-freefont-ttf fixed the problem.

sudo apt-get install --reinstall fonts-freefont-ttf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.