After installing elementary OS Loki on my laptop (Lenovo Flex 3), when I press towards the middle of the click bar on my touchpad, it will copy or paste depending on the location. I've gone into Mouse & Touchpad settings and changing the physical click setting can disable copy and paste but also takes away my ability to "right click" with the right side of the click bar. I want to be able to right click using my touchpad but this copy and paste has to go. Any suggestions?

  • This solved my problem (although it's a bit overkill, disabling the middle click entirely). The solution above it may work as well, but haven't had time to try it. I'll write up an answer later tomorrow if I have time and no one beats me to it. askubuntu.com/a/55988/521915
    – CyberEd
    Commented May 1, 2017 at 1:23

1 Answer 1


I also used the xmodmap solution, but this disables the middle mouse completely. Another solution is installing the gnome-tweak-tool from the AppCenter and disabling Middle-click Paste: https://askubuntu.com/a/872165/519324

I opened an issue for this. As of elementary OS 5 and 5.1, it has been resolved and there is now a toggle in System SettingsMouse & TouchpadClicking called Middle click paste that can enable or disable this behavior.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.