3

As a developer I want to use the Netbeans IDE Shortcuts in elementar OS 0.4. But I can not deactivate XWindow shortcuts that conflict with Netbeans' shortcut. Example: Alt+F7

It is not listed in Settings - Keyboard - Shortcuts - Windows...

4

Let's do it from gsettings:

gsettings list-recursively | grep \<Alt\>F7

This finds all actions set to that keybinding. For instance, mine:

org.gnome.mutter.wayland.keybindings switch-to-session-7 ['<Primary><Alt>F7']
org.gnome.desktop.wm.keybindings begin-move ['<Alt>F7']

Set any conflicts to blank ('') or another keybinding. For example,

gsettings set org.gnome.desktop.wm.keybindings begin-move "['']"

Voilà! And if you ever want to restore the default, use this format:
gsettings reset org.gnome.desktop.wm.keybindings begin-move

  • This worked for me. I think that these keybindings should appear in Keyboard Settings as the OP mentioned. I use this shortcut in IntelliJ often. – Russell Jan 17 at 18:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.