4

Just tried installing this on my laptop, completely new to Linux.

I managed to find out from other answers that the issue is that there is no native support for my network card, and that I need to download a new kernel. Problem is I don't have internet to download it with: Intel 8260 drivers not working, no ethernet and cant bluetooth tether for updated kernel

I have no ethernet port and I could not get the network from my phone to my computer. I could connect the phone and the computer successfully, but there is still no internet connection.

If anybody knows a workaround to either problem, I would be grateful!

Edit: This appears to be a problem with several units of Xiaomi Mibook Air laptop.

4

Solution by Demelza:

  1. Open a terminal and type the command: rfkill list

    It will list all your network hardware available, and you should notice one that's called "acer-wireless". Looks like Linux kernel loads an Acer module, which conflicts with our Wi-Fi chip.

  2. You can deactivate it for the current session with the command: sudo modprobe -r acer-wmi

    Your Wi-Fi should now be working as intended.

  3. If you want to make it permanent, just edit your /etc/modprobe.d/blacklist.conf file and add the following line at the bottom of the file: blacklist acer_wmi

    It'll blacklist the conflicting module and you'll have fully working Wi-Fi.

  • On my 13'3 mibook sudo modprobe -r acer-wmi disable my keyboard and touchpad but if I blacklist the module and then reboot everything works – WonderLand Nov 24 '16 at 7:04
1

Download in your phone:

https://wireless.wiki.kernel.org/_media/en/users/drivers/iwlwifi-8000-ucode-25.30.13.0.tgz

Copy it to your home folder (you said your phone was conected otherwise try using bluetooth)

Extract it to your home folder:

tar -zxvf iwlwifi-8000-ucode-25.30.13.0.tgz

then in terminal

cp iwlwifi-*.ucode /lib/firmware

Reboot

The solution came from:

https://forums.linuxmint.com/viewtopic.php?t=209496

What I've done is figure out how you can get the file using your phone and make it available in your computer. Have in mind this answer was aimed for Linux Mint. Solution not tried by me. I hope it works.

  • Nothing seemed to happen after doing this. I followed the steps but the issue remains. – David Hasselberg Oct 18 '16 at 22:06
  • Try downloading the kernel .deb files to your phone as you said in first place and copy them to your computer. Install them as you normally install .deb packages. Read carefully: tipsonubuntu.com/2016/10/03/… – Jorge R. Marín Oct 18 '16 at 23:18
  • What kernel files should I take? I took the ones at the top that said amd64. I have a 64 bit system. I could not install them though, I got the error message at the end of installation "Can't drop privileges for downloading as file..." – David Hasselberg Oct 19 '16 at 16:11
  • I could install them now successfully, and uname -r says I'm running 4.8. However, this did not solve my problem either. Still the wifi cannot be turned on. – David Hasselberg Oct 19 '16 at 16:18
  • No more ideas. :( Try intel official help intel.com/content/www/us/en/support/network-and-i-o/… – Jorge R. Marín Oct 19 '16 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.