1

When first booting up my MacBook Pro running Elementary OS, there's a rather loud startup sound effect. I have my desktop volume turned all the way down and also toggled off, however this doesn't seem to affect the startup sound.

Is there any way to disable this?

  • How are you booting into elementary OS? Live USB? Dual boot? Is OS X still on your system? – wolf Oct 3 '16 at 19:35
1

This will depend on how you're booting into elementary OS. Most of the solutions I found were specific to booting into OS X, so you might have more options if you still have OS X installed and/or are dual-booting. The startup chime should respect the latest software settings. I'd try the following:

  • Mute the audio in OS X and see if the chime plays on reboot.

or

  • Run osascript -e 'set volume with output muted' in Terminal before exiting OS X and see if the chime plays on reboot, or whether it continues to play on reboot after only booting into elementary OS.

As far as I know, there is no easy way to touch that osascript (AppleScript) functionality in Linux, but here is a lead if you want to hack around. If none of the above works, I'd attempt some commands from here or here, but do report back so we can find out what works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.