1

Upgrading fails because of the package appstream-data-pantheon-loki-stable-icons:

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree         
Reading state information... Done  
You might want to run 'apt-get -f install' to correct these.  
The following packages have unmet dependencies:  
 appstream-data-pantheon-loki-stable-icons : Depends: appstream-data-pantheon-loki-stable but it is not installed  
E: Unmet dependencies. Try using -f.

$ sudo apt-get -f install  
Reading package lists... Done  
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:  
  appstream-data-pantheon appstream-data-pantheon-icons
Use 'sudo apt autoremove' to remove them.  
The following additional packages will be installed:  
  appstream-data-pantheon-loki-stable  
The following NEW packages will be installed:  
  appstream-data-pantheon-loki-stable  
0 upgraded, 1 newly installed, 0 to remove and 28 not upgraded.  
8 not fully installed or removed.  
Need to get 0 B/70,2 kB of archives.  
After this operation, 78,8 kB of additional disk space will be used.  
Do you want to continue? [Y/n]   
Selecting previously unselected package appstream-data-pantheon-loki-stable.  
(Reading database ... 266701 files and directories currently installed.)
Preparing to unpack .../appstream-data-pantheon-loki-stable_0.4+r13~ubuntu0.4.1_all.deb ...  
Unpacking appstream-data-pantheon-loki-stable (0.4+r13~ubuntu0.4.1) ...  
dpkg: error processing archive /var/cache/apt/archives/appstream-data-pantheon-loki-stable_0.4+r13~ubuntu0.4.1_all.deb (--unpack):  
 trying to overwrite '/usr/share/app-info/yaml/pantheon_xenial-main_amd64.yml.gz', which is also in package appstream-data-pantheon 0.3.0-0~10~ubuntu0.4.1  
Processing triggers for appstream (0.9.4-1ubuntu1) ...  
AppStream cache update completed successfully.  
Errors were encountered while processing:  
 /var/cache/apt/archives/appstream-data-pantheon-loki-stable_0.4+r13~ubuntu0.4.1_all.deb  
E: Sub-process /usr/bin/dpkg returned an error code (1)  

Additional Info: First I had the beta version of elementary OS installed and then upgraded to the stable 0.4 version - don't know if this has something to do with it.

closed as off-topic by Hasan Oct 22 at 3:31

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "The Question is about a release or feature that has been significantly updated, to the point at which upgrading fixes the issue or answers the question." – Hasan
If this question can be reworded to fit the rules in the help center, please edit the question.

0

sudo dpkg -i --force-overwrite /var/cache/apt/archives/appstream-data-pantheon-loki-stable_0.4+r13~ubuntu0.4.1_all.deb

  • 3
    This answer could be more helpful if it described the command and why it solves the issue – wolf Oct 31 '16 at 20:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.