5

I have an issue with shaky mouse pointer when I'm using touch pad, but only when I'm using one finger.

It doesn't happen when I use:

  • two fingers to scroll (cursor doesn't move, but I can scroll up and down by moving my fingers).
  • USB mouse.
  • Ubuntu (I installed Ubuntu just to check if there is an issue with some driver/settings or with touch pad itself, but issue doesn't happen on Ubuntu).

I also tried this, but with no luck - http://useful-linux-tips.blogspot.com/2013/04/get-rid-of-shaky-touchpad-pointer.html

  • Out of curiosity, are you running Freya or Loki? – wolf Oct 1 '16 at 20:24
  • I use Loki (0.4). – Laran Oct 1 '16 at 20:53
  • I had the same error and I did the steps that wolf said, now my touchpad is working correctly. Thanks, for you all my laptop is Toshiba Satellite. :) :D – Nasked Dec 21 '16 at 6:01
  • I just installed Elementary OS for the first time. I have a Dell Latitude E6430 Laptop and a shaky mouse (for me, the two-finger scrolling not working properly is worst) I'm on 0.4.1 Loki with both of the proposed solutions I'm getting this: > Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: >The following packages have unmet dependencies: xserver-xorg-in – pipsfips Jun 17 '17 at 22:01
5

This is a bug reported here if you could contribute your laptop model there for testing purposes. (The issue appears to be that the synaptics driver does not take precedence over the libinput driver.)

Some of the reporters had some success from installing synaptics and changing libinput's priority:

  1. sudo apt install xserver-xorg-input-synaptics
  2. sudo mv /usr/share/X11/xorg.conf.d/90-libinput.conf /usr/share/X11/xorg.conf.d/45-libinput.conf

Give that a reboot and let us know how it goes? It would also be useful to report back to the bug discussion.

  • Touchpad works fine now, thanks. I added a comment to bug tracker with my laptop model:) – Laran Oct 1 '16 at 19:28
  • My problem was with mousepad doing a "ladder" while sliding the pointer. The above solution solved my problem, thank you! My computer: - Acer M5 481pt; - Touchpad Elantech; - Elementary OS Loki; – Savio Camacam Feb 5 '17 at 2:33
  • Confirm it works – Johnny Doe Feb 22 '17 at 10:30
  • This broke my computer. xserver-xorg-input-synaptics depends on server-org-core. Install that and my input devices don't work anymore. Going to try to boot recovery and revert to libinput. – jorfus May 11 '18 at 2:21
1

In case you want to continue using libinput instead of synaptics (which is deprecated), you can try manually upgrading libinput which fixed the problem on my Dell Latitude E7240.

From the following links:

https://launchpad.net/ubuntu/+source/libinput

https://launchpad.net/ubuntu/+source/libwacom

https://launchpad.net/ubuntu/+source/xserver-xorg-input-libinput

I downloaded the following packages:

https://launchpad.net/ubuntu/+archive/primary/+files/libinput10_1.5.3-1ubuntu1_amd64.deb

https://launchpad.net/ubuntu/+archive/primary/+files/libinput-bin_1.5.3-1ubuntu1_amd64.deb

https://launchpad.net/ubuntu/+archive/primary/+files/libinput-dev_1.5.3-1ubuntu1_amd64.deb

https://launchpad.net/ubuntu/+archive/primary/+files/libinput-tools_1.5.3-1ubuntu1_amd64.deb

https://launchpad.net/ubuntu/+archive/primary/+files/libwacom2_0.22-1_amd64.deb

https://launchpad.net/ubuntu/+archive/primary/+files/libwacom2-dbg_0.22-1_amd64.deb

https://launchpad.net/ubuntu/+archive/primary/+files/libwacom-bin_0.22-1_amd64.deb

https://launchpad.net/ubuntu/+archive/primary/+files/libwacom-common_0.22-1_all.deb

https://launchpad.net/ubuntu/+archive/primary/+files/libwacom-dev_0.22-1_amd64.deb

https://launchpad.net/ubuntu/+archive/primary/+files/xserver-xorg-input-libinput_0.23.0-2_amd64.deb

https://launchpad.net/ubuntu/+archive/primary/+files/xserver-xorg-input-libinput-dev_0.23.0-2_all.deb

Once downloaded, open a terminal, change to the directory you downloaded them, and run:

sudo apt install ./*.deb

You'll then want to restart, and hopefully your problems will be fixed.

  • You should really make it clearer that the packages need to be downloaded to their own directory, otherwise when sudo apt install ./*.deb is run it will install any other .debs in the Downloads directory which is definitely not good. – Mike Wild Jan 26 '17 at 22:43
  • @vwbkn How can I revert the upgrade without removing several core elementary packages? – Giulio Sant Mar 18 '17 at 17:22

protected by Community Jul 6 '17 at 19:43

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.