1

I recently installed Loki on VM to test it out, but to my surprise it is sluggish and choppy. I have enabled 3d acceleration and 128mb graphic, 10gb ram and 4 cores of i7 with 100% limit.

What could be the reason? How to fix it?

  • I'm running VirtualBox on a MacOS host and I have found Loki to be quite sluggish. I have configured 128MB video RAM, 4GB RAM, 3D acceleration, and 2 cores — the same setup as I use for my Freya guest. Freya runs very smoothly, but Loki is unacceptable. Given that Feroiso is giving his guest installation much more resources than I am, and he's experiencing the same sluggishness and choppy response I'd conclude that Loki needs more development. – Neal Scroggs Oct 9 '16 at 18:16
  • 3D Acceleration requires guest additions for support, otherwise disable both 3D and 2D support. – Lewis Goddard Oct 12 '16 at 2:13
1

Try disabling all video acceleration. Uncheck 3D acceleration. Do not check 2D acceleration. I did this and performance improved markedly. The problem seems to be graphics rendering.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.