2

I'm on Elementary OS 0.4 and i've a problem with the wifi connection, i tryied to fix it with all i've found on the web, but it still doesn't work. With " lshw -C network " i got that:

*-network UNCLAIMED
   description: Network controller
   product: BCM43142 802.11b/g/n
   vendor: Broadcom Corporation
   physical id: 0
   bus info: pci@0000:03:00.0
   version: 01
   width: 64 bits
   clock: 33MHz
   capabilities: bus_master cap_list
   configuration: latency=0
   resources: memory:f7800000-f7807fff

Could anyone help me? I'm a noob.

4
  • Surfing on the web i read about a blacklist so i use this command to verify and i get this: 'grep -R brcm /etc/modprobe.d /etc/modprobe.d/blacklist-bcm43.conf:blacklist brcm80211 /etc/modprobe.d/blacklist-bcm43.conf:blacklist brcmfmac /etc/modprobe.d/blacklist-bcm43.conf:blacklist brcmsmac' Oct 1 '16 at 11:20
  • @lemonslice with the command iwconfig i get: enp2s0 no wireless extensions. (that is the Ethernet interface) lo no wireless extensions. (i don't know what is this) Oct 1 '16 at 14:18
  • Instead of writing "SOLVED" in your questions title please accept the best answer by clicking the checkmark ✓
    – quassy
    Oct 1 '16 at 23:39
  • How did you fix it? I now have the same problem. How did you disable secure mode? Oct 29 '19 at 17:46
3

SOLVED the problem was that secure boot was enabled, now wireless connection is shown in the option and works!

1
  • Hi Andrea, this answer might be more helpful to other searchers if you added the steps you took to rectify your issue
    – wolf
    Oct 1 '16 at 19:13
2

You're missing the Broadcom drivers, open terminal and paste

sudo apt install bcmwl-kernel-source

Reboot your machine and try to connect to the wifi.

3
  • Thank you Giovanni, this is what i got now: bcmwl-kernel-source is already the newest version (6.30.223.248+bdcom-0ubuntu8). Oct 1 '16 at 8:49
  • Is the wifi working now? Oct 4 '16 at 10:31
  • Yes, now it works, but the problem was the secure boot enabled! Oct 5 '16 at 11:18
1

You might have to execute iwconfig manually (the card is there but it is down):

sudo ifconfig wlp4s0 up
service network-manager restart

(Source: https://askubuntu.com/questions/760075/cant-view-wifi-networks-after-upgrading-to-ubuntu-16-04)

0

In my case with Hp laptop the solution was disable secure boot and enable legacy tutorial here https://support.hp.com/us-en/document/c04784866

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.