I've tried following other guides for Ubuntu on this, but no dice. I keep getting this error after running

sudo ./AdobeAIRInstaller.bin

error: /tmp/air.7AG64G/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

When i followed all the other guides to install required libraries, it can't find anything! I'm running on a live USB on a macbook air 2014

  • 3
    why do you need adobe air?, if you check Adobe's page it says that isn't supported anymore in linux – Alexandr Sep 30 '16 at 15:49
  • I'm setting up a USB stick for my 8 year old son so he can just Scratch programming offline, which requires Adobe Air unfortunately... – Craig Skipsey Oct 2 '16 at 16:45
  • 1
    Hey Craig, would you please write up your solution as an answer so other searchers can benefit from your research in the future? – wolf Oct 6 '16 at 3:54

Ok, after much effort, I finally got this to work. Here's how:

sudo apt-get -f install

sudo dpkg --add-architecture i386

sudo apt-get install libxt6:i386 libnspr4-0d:i386 libgtk2.0-0:i386 libstdc++6:i386 libnss3-1d:i386 libxml2:i386 libxslt1.1:i386 libcanberra-gtk-module:i386 gtk2-engines-murrine:i386 

Note: the above command is similar to other tutorials, but without lib32nss-mdns:i386 as it couldn't be found. This was a huge PIA and a lot of googling to find the answer, so the replacement can be installed with:

sudo apt-get install libnss-sss:i386

Then, as with other tutorials, create the symbolic links with:

sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0


sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0

Then finally, make the Adobe installer executable with:

sudo chmod a+x AdobeAIRInstaller.bin

Then install it:

sudo ./AdobeAIRInstaller.bin

Now, it takes some time for the dialog to show after the above command, so give it a while. But when finished, you should see Adobe Air in your applications.

Then for completeness, delete the symbolic links with

sudo rm /usr/lib/libgnome-keyring.so.0


sudo rm /usr/lib/libgnome-keyring.so.0.2.0

So after all that, I tried to install Scratch 2.0 Offline (which was the whole point of the exercise) and it didn't work! Then I changed the permissions of the .air file to full read write execute for both current user and sudo and voila, it worked!

| improve this answer | |

Try this tutorial, it should work


| improve this answer | |
  • Tried that on eOS Loki, no dice, says script is only for Ubunut x.xx etc – Craig Skipsey Oct 2 '16 at 21:07
  • Also tried "sudo dpkg --add-infrastructure i386" then when I run the Adobe installer again, I get an error relating to libstdc++ – Craig Skipsey Oct 3 '16 at 10:28
  • From further research it seems I need the ia386-libs, but alas it still wont install!!! Anyone know a manual way I can do that? – Craig Skipsey Oct 3 '16 at 23:30
  • Try downloading it from here packages.ubuntu.com/precise-updates/ia32-libs – Giovanni Caligaris Oct 4 '16 at 10:31
  • huzzaaah!! Did a "sudo apt-get -f install" then ran the Adobe Air binary – Craig Skipsey Oct 4 '16 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.