1

I installed Loki successfully on a Mac Mini 2011 a couple of days ago. Everything is working fine, but hardware acceleration (which I don't need) and the Display Port output (which I do need).

That's what lshw -C video gives me:

  *-display UNCLAIMED     
       description: VGA compatible controller
       product: Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:90000000-9fffffff memory:a8800000-a881ffff ioport:2000(size=256) memory:a8820000-a883ffff
  *-display UNCLAIMED
       description: Display controller
       product: 2nd Generation Core Processor Family Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 09
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm cap_list
       configuration: latency=0
       resources: memory:a8000000-a83fffff memory:a0000000-a7ffffff ioport:3000(size=64)

And glxgears -info says:

GL_RENDERER   = Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits)
GL_VERSION    = 3.0 Mesa 11.2.0
GL_VENDOR     = VMware, Inc.

The radeon driver is installed, but if I understand correctly, not used. I don't care about the driver I'm using, as long as I can attach a second screen.

Any ides on what to do?

Many thanks in advance!

  • Is this in a virtual machine (VMware)? – wolf Sep 30 '16 at 9:49
  • No, it's not. It's elementary booted on a Mac Mini. What makes you think that's a virtual machine? The llvmpipe? I think that's because I'm booting with nomodeset, because everything else gives me a black screen. Apart from installing the amdgpu pro driver, which makes the system horribly slow and characters appear in > 15 seconds after I pressed them. – user6689 Sep 30 '16 at 14:18
  • What is the resolution / model of the monitor attached to the Display Port / Thunderbolt output? Maybe this helps: nsrc.org/workshops/2015/nsrc-icann-dns-ttt-dubai/raw-attachment/… (P.S.: Very good and detailed first question ;) ) – quassy Oct 1 '16 at 22:25
  • The display is 1600x1200 connected via a Thunderbolt to DVI adapter. And thanks for the link! Sadly, I'm already using nomodeset, which might be part of the problem, because as far as I understand radeon needs kernel mode setting in newer versions. – user6689 Oct 3 '16 at 11:51
0

I'm on a 2011 mini. I had to use nomodeset as well, but decided to install refind boot manager to make customizing boot options easier. With it I was able to get the mini to boot without nomodeset and without proprietary drivers. Whistler is workin well for me. I haven't tried two monitors at once but I have tried both hdmi and the mini display port. Both are working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.