I am not certain if this is Ubuntu specific or elementary OS specific.

On the lock screen, I do not have the capability to change my brightness using the dedicated keys on my keyboard.

It turned problematic when I had turned my brightness all the way down, when leaving the desk, and returned to a screen that had turned off (lock computer when away for x minutes), and effectively rendered nothing upon 'wake' because the brightness was set to 0 before I left the desk.

I could not turn it back on. Luckily, entering the password, hitting Enter and then changing the brightness rescued me -- but that is not an ideal solution.

I'm currently using nvidia drivers installed via sudo ubuntu-drivers autoinstall

  • Do your brightness keys work once you're logged in?
    – wolf
    Commented Sep 30, 2016 at 6:14
  • 1
    @wolf - I should have clarified that. Yes - it works fine once logged in. Commented Sep 30, 2016 at 16:35
  • Did you ever find a way out of this? I mean I guess you're life would be easier using lock manually, rather than dimming the screen entirely. Did you have long running process and need to save battery something? Commented Feb 9, 2017 at 16:47

2 Answers 2


I make my own brightness hotkeys using xbacklight.

sudo apt-get install xbacklight

After xbacklight is installed:

  • Go into System Settings
  • Keyboard
  • Custom

There is a little plus sign on the bottom right that says "add" when you hover over it.

Make two custom commands

xbacklight -inc 8
xbakclight -dec 8

Set the keys for these to

(ctrl + (brightness up key))

(ctrl + (brightness down key))

On my laptop I use (ctrl + f5) and (ctrl + f6) for my brightness keys.

What this is done it is possible that you can set your brightness to zero and get no video output. When that happens you will have to press the keys to increase your brightness to get your video back.


This is also an ongoing issue for me. Looks like after some research it has to do with nvidia drivers. I was hoping this was looked into for the 0.4.1 release. Has anyone else found any other fixes other than xbacklight?

  • Tried installing xbacklight and it did map new buttons but its not the buttons that do not work. when hit Ftn + up or down the slider moves just no change. I messed around with a bunch of commands when I tried this in other distos(ubuntu) and it just made my screen black when I rebooted.
    – Mwebbs
    Commented May 18, 2017 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.