1

When I open the Reader View in Firefox, it adds some disturbing static, whenever sound is played (e.g. youtube, music player, system sounds from the wingpanel...).

Neither exiting the Reader View nor closing Firefox will fix this, but logging out and in again does.

I even tried capturing it with audacity and this guide, but surprise, the static will not appear in the recording.

I'm not sure if this is an issue of Firefox or elementary OS, but I figured, it might as well be one of elementary, as closing Firefox does not fix it.

1

I had this issue on (K)ubuntu 16.04.1 - there seems to be a problem with HDMI for some sound drivers. (I have a Radeon HD 7970 series sound card.)

The first solution here worked for me: https://askubuntu.com/questions/405071/static-and-crackling-in-my-hdmi-audio

From this discussion https://bbs.archlinux.org/viewtopic.php?id=116172 comes an explanation of the setting:

tsched=0 disables PulseAudio's timer-based scheduling and uses the classic interrupt-driven approach. Timer-based scheduling allows for better latency management and reduced CPU usage. It puts very strict requirements on the ALSA drivers. Unfortunately, some drivers do not handle it well.

I suspect the problem is immediately caused by the text-to-speech module in Firefox Reader View but not sure how.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.