0

I can't install packages because of an unknown error.

$ sudo add-apt-repository -y ppa:otto-kesselgulasch/gimp
$ sudo apt-get update
$ sudo apt-get install gimp
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 gimp : Depends: libgimp2.0 (>= 2.8.18) but it is not going to be installed
        Depends: libgimp2.0 (<= 2.8.18-z) but it is not going to be installed
        Depends: gimp-data (>= 2.8.18) but it is not going to be installed
        Depends: gimp-data (<= 2.8.18-z) but it is not going to be installed
        Depends: libbabl-0.1-0 (>= 0.1.10) but it is not going to be installed
        Depends: libgegl-0.3-0 (>= 0.3.0) but it is not going to be installed
 xdgurl : Depends: python-tk (>= 2.7.0) but it is not going to be installed
          Depends: python3-tk (>= 3.2.0) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
3

The script says "You might want to run 'apt-get -f install' to correct these". Have you tried running sudo apt-get -f install? It will attempt to correct broken dependencies. Afterwards, you would want to try to install each of those programs on which GIMP depends (that's what makes them dependencies).

-1

Try to run sudo apt-get update then folowed by sudo apt-get install -f

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.