14

Transparency makes the text hard to read, and has zero benefit that I've ever been able to see. How do I turn it off? At least in Pantheon Terminal, ideally wherever it might occur.

20

In order to turn off transparency, open a terminal session and run the following commands, depending on your version of elementary OS:

0.4 Loki

Turn off transparency in WingPanel

gsettings set org.pantheon.desktop.wingpanel use-transparency false

Turn off transparency in Terminal

gsettings set org.pantheon.terminal.settings background "rgba(37, 46, 50, 1.0)"

0.3 Freya

Turn off transparency in WingPanel

gsettings set org.pantheon.desktop.wingpanel auto-adjust-alpha false
gsettings set org.pantheon.desktop.wingpanel background-alpha 1.0

For this change to have an effect, WingPanel needs to be reloaded (log off & log on again).

Turn off transparency in Terminal

gsettings set org.pantheon.terminal.settings opacity 100

Reset to default

Use the gsettings reset command to restore the default value of a setting, for example to turn back on WingPanel transparency in 0.4 Loki:

gsettings reset org.pantheon.desktop.wingpanel use-transparency
  • To restart wingpanel you just have to kill it, and cerbere will restart it. – RolandiXor Aug 18 '15 at 23:20
  • on juno 0.5 i receive an error: gsettings set org.pantheon.desktop.wingpanel use-transparency false – citykid Jan 23 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.