6

Everytime I open Chrome a window pops-up (see below) and asks me to set up a new keyring. I did a quick research and learned that it might happen because user login is disabled on start. I switched that on but still got the same pop-up. How can I remove/turn off/disable it?

enter image description here

  • I followed the instructions found here - elementaryos.stackexchange.com/questions/676/… Option #1 - installing seahorse - I unlocked the default keyring in Passwords & Keys but it did not solve my problem, it kept popping up. Then I deleted it which did not help either. Option #2 - command line (rm ~/.local/share/keyrings/login.keyring ) - got this answer in terminal rm: cannot remove '/home/name/.local/share/keyrings/login.keyring': No such file or directory What else should I try now? – n00b Sep 28 '16 at 8:43
2
+50

Okay! After some heavy digging,

  1. First, update Chrome (⋮ in upper-right corner > Help > About Google Chrome)—a fix has already been submitted but it did not fix all issues. Then subscribe to the bug report and report your issue so the devs know they can ask for your help testing a potential fix.
  2. If the update doesn't fix it, try running Chrome with the --password-store=basic flag:
    google-chrome-stable --password-store=basic
    If you want to set your Chrome icon to run this command, see this answer.

If that doesn't work, you're looking at playing around with your keyrings, which are in ~/.local/share/keyrings. But I'd sooner recommend that you follow the latest alternative advice in the the bug report.

  • Hi wolf!Thank you for doing some research! – n00b Oct 19 '16 at 16:53
  • Hi wolf! Thank you for doing some research! I have the same issue when open Opera, my default browser but do not have it with any other browsers. I've tried all that you posted above. 1. chrome is up to date 2. it works well - no keyring pop-up 3. mv: cannot stat '/usr/bin/gnome-keyring-daemon': No such file or directory Basically, it is still theere when I open Opera/Chrome. – n00b Oct 19 '16 at 16:59
  • So it looks like --password-store=basic is the fix for now. If you want to update your shortcut, you can add that flag to its .desktop file – wolf Oct 20 '16 at 6:12
  • The annoying pop-up has just disappeared (after restarting my computer several times). I suppose option #2 fixed it. Thanks! – n00b Oct 20 '16 at 11:59
0

Check if it's the GNOME keyring as it's probably based in it, and if it's in the startup applications.

Also, have you tried to really make the keyring? It's improved security, and it will keep your logins in the keyring.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.