2

i really like freya. but i have tried everything and it does not recognize the synaptic touchpad. Help, please?

  • 1
    Would you mind to add a list of "everything" you tried? It's easier to help you if we know what did not work :) – embik Jul 27 '15 at 18:54
  • at first i thought it must be disabled from bios, it wasn't. i tried getting the id and enable it from the terminal, it din not have an id. i also tried sudo modprobe -r psmouse sudo modprobe psmouse proto=imps did nothing. – Andrada-Mara Ardelean Jul 29 '15 at 6:57
  • i tried reinstalling sudo apt-get --purge autoremove xserver-xorg-input-synaptics && sudo apt-get install xserver-xorg-input-synaptics. still nothing. updated kernels, nothing – Andrada-Mara Ardelean Jul 29 '15 at 6:57
6

Answered already in the previous answer's comments. Restating here for the upcoming users, so it would be easy to follow.

Solution:

sudo add-apt-repository ppa:hanipouspilot/focaltech-dkms
sudo apt-get update
sudo apt-get install focaltech-dkms
sudo modprobe -r psmouse 
sudo modprobe psmouse

Note: This works on all debian based distros (Ubuntu, elementary OS and so on)

  • I'm facing the same issue on Asus X555U. If i run xinput list i don't even see any touchpad... it just list Virtual core XTEST pointer. Does this solution will work for me even if i don't see FocalTech emulation mode? – Luciano Dec 18 '15 at 7:57
2

X55 series uses elantech touchpad. Upgrade to kernel 4.0 or above it will solve the problem.

  • updating kernel did not work for me :( but thank you – Andrada-Mara Ardelean Jul 29 '15 at 7:03
  • can you post the result of xinput list – personinsack Jul 29 '15 at 7:52
  • Virtual core pointer id=2 [master pointer (3)] ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)] ⎜ ↳ Microsoft Microsoft Nano Transceiver 1.1 id=12 [slave pointer (2)] ⎜ ↳ Microsoft Microsoft Nano Transceiver 1.1 id=13 [slave pointer (2)] ⎜ ↳ PS/2 FocalTech FocalTech Touchpad in mouse emulation mode id=16 [slave pointer (2)] – Andrada-Mara Ardelean Jul 29 '15 at 7:57
  • Virtual core keyboard id=3 [master keyboard (2)] ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)] ↳ Power Button id=6 [slave keyboard (3)] ↳ Video Bus id=7 [slave keyboard (3)] ↳ Video Bus id=8 [slave keyboard (3)] ↳ Sleep Button id=9 [slave keyboard (3)] – Andrada-Mara Ardelean Jul 29 '15 at 7:57
  • ↳ USB Camera id=10 [slave keyboard (3)] ↳ Microsoft Microsoft Nano Transceiver 1.1 id=11 [slave keyboard (3)] ↳ Asus WMI hotkeys id=14 [slave keyboard (3)] ↳ AT Translated Set 2 keyboard id=15 [slave keyboard (3)] – Andrada-Mara Ardelean Jul 29 '15 at 7:57
0

I have similar issues.so i tried different kernel and works only fine in 4.2.0-36-lowlatency . When i tried linux-image-4.4.0-31-generic the touch pad was not stable and had some random issues with clicks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.