Normally I've found all I need without asking a question, so please forgive me for making my first post on Stackexchange. Basically on Freya, and in Windows, my wifi and ethernet connection is fine, however on Loki 0.4 (the official release), the wifi works for 5 seconds at best, and the ethernet is the same. When it stops working, Epiphany shows a 'temporary' DNS error, it can't find the IP. I tried using IP addresses instead of domain names and it worked as far as I can tell, so it must be a DNS error.

I tried ubuntu 16.04.1 and when I activate the additional drivers for my broadcom and intel chips the wifi and ethernet works fine, but before that the wifi card isn't even recognised, so it's a different problem to that of Loki where the wifi card is recognised right out of the box, just the DNS is not working.

I've tried manually adding in as the DNS server, I've tried turning everything off and on again (restarting services), I've tried everything I've been able to find about resolvconf and network manager, but nothing was fixed the problem. I changed and installed Ubuntu Studio in the meantime, and I've been using the live usb of Loki to test for DNS fixes, it behaves the same way as my past install of Loki. Something specific to Loki 0.4 is messing with the DNS on my machine and making the DNS calls all fail after about 5 seconds of a connection.

I can't be the only one with this problem... Has anyone got any solutions for this type of problem (may not be Loki specific for others).

Thanks for your time, AB

By the way, computer: Lenovo Thinkpad E330

  • pastebin.com/R8H8Pw8P ^ A tail of the syslog, at the bottom is the disconnecting event Commented Sep 26, 2016 at 13:40
  • Is the remove-custom-dns.service something you have installed?
    – Mike Wild
    Commented Sep 26, 2016 at 14:12
  • EDIT: Looks like it is an elementary script. The fact this service is failing is somewhat worrying. What are the contents of /etc/resolve.conf?
    – Mike Wild
    Commented Sep 26, 2016 at 14:23
  • Hi Mike, thanks for the help. resolv.conf had the nameserver as which I hear is standard, and the other DNS server given was my ISP's DNS server which I know works from my Windows install. I took a new tail with a new installation, after reinstalling the broadcom kernel and the new driver in the solution below this: pastebin.com/91DqutkF Commented Sep 28, 2016 at 13:48

3 Answers 3


Same problem for my Lenovo. It seems to be something related to the Ethernet hardware power management.

You need to install a new driver.

sudo apt install linux-headers-generic build-essential git
git clone https://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
sudo make install
sudo reboot 
  • Thanks so much for this. It helped a bit, the connection maybe lasts 20 seconds longer, but the main problem is still happening. DNS errors after a short while. Commented Sep 28, 2016 at 13:44

Thanks for everyone's help. I believe that through a combination of every solution given here, and this solutions first answer (the first half of the first answer) I have solved the wifi issue it seems. Although the connection is a bit slow, it seems ok for the moment. Hopefully sometime soon this hardware will get some more support out of the box to make elem OS more accessible.


You must to disable N to better performance. If your connection drop down after some minutes of use, disable power management. You can do this adding these options in a config file. From terminal:

echo "options iwlwifi 11n_disable=8 power_save=0 " | sudo tee /etc/modprobe.d/iwlwiwi.conf

Then restart and share your experience.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.