I've been using Loki for about 3 weeks. Installing software and updates was working fine. I booted into Loki today and got a notification that I had 4 updates available. The red flag also appeared on the App Center icon on the dock. I launched App Center and clicked on the Update tab. The Update window had the following error message: "No Results. No apps could be found. Try changing search terms." enter image description here

I also tried to install two different software programs: virtualbox and gdebi. I tried them each separately. I had the same result both times. After clicking on the Install button the Starting progress bar appeared. I waited 5 minutes with each program and nothing else happened - no progress was shown on the progress bar. I clicked the Cancel button and the installation was canceled each time. enter image description here

I have no idea as to what I should do next. Anybody have any suggestions?

  • Welcome to the "App Centre" freezing club! Ive had the exact problem for weeks now and no solution yet, install Ubuntu Software instead it works and it updates the system as well!
    – user6602
    Commented Sep 26, 2016 at 9:29
  • Does running sudo apt update help? See this ticket for more information: elementaryos.stackexchange.com/questions/7533/… Commented Sep 26, 2016 at 15:59
  • Problem is still there after running sudo apt update.
    – tfdjim
    Commented Sep 27, 2016 at 22:58

6 Answers 6


A fix for this specific issue has just been released in the form of a new packagekit version. If this is not applied automatically, you can do it with the following two commands:

sudo apt update
sudo apt install packagekit

Detailed instructions can be located at https://medium.com/elementaryos/important-update-released-501c9d9f28b


This is similar (not identical) to a bug in Loki reported recently.

Please mark yourself as affected here (in case you are not the one who opened the bug) if you feel this bug represents your issue: https://bugs.launchpad.net/appcenter/+bug/1628324

  • After looking at the png images, this is similar to but not the same as my problem. Thx for the info.
    – tfdjim
    Commented Sep 29, 2016 at 23:37

Another issue on appCenter may be related to warning/error messages that generates freezing loops.

  • on console, use sudo apt update and check for any warning messages:

    apt update warning message

  • I solved that problem removing the address package from the package list on /etc/apt/sources.list


I have a problem like you

you need open terminal and do this command :

sudo apt update
sudo apt install packagekit
sudo dpkg --configure -a

When you run "sudo dpkg --configure -a" the system need your new enroll key machine type and retype

after that viola!! your appcenter running well again!!


Need to report the AppCenter bug. Ubuntu Software updater currently fetch Ubuntu base, kernel and other software updates but I did not find any elementary base updates. I don't know whether Software updater fetches elementary base updates too.

  • I'd prefer to stay within the elementary software so I won't install the Ubuntu software updater.
    – tfdjim
    Commented Sep 29, 2016 at 23:36
  • Then the only way is to use sudo apt-get upgrade to get the updates or even this an invalid command to update latest elementary updates. I assume sudo apt-get upgrade doesn't get elementary base updates.
    – user64287
    Commented Oct 11, 2016 at 23:36

In my case, the app center stopped to work (updates and new install) after removing some apps that I didn't want anymore.

What I did to back it work again is to install all packages required to build the appcenter. Just follow the list on the git repository (https://github.com/elementary/appcenter):

sudo apt-get install intltool libappstream-dev libgee-0.8-dev libgranite-dev libgtk-3-dev libjson-glib-dev libpackagekit-glib2-dev libsoup2.4-dev libunity-dev libxml2-dev libxml2-utils valac

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.