1

I´m using a HP Stream 13 which has a Realtek RTL8723BE (or similar) wifi/bluetooth chip with elementary OS Loki 0.4.

Wifi is always working after reboot of system. Sometimes my network show great strengh, sometimes the signal is very low. It changes dramaticaly even when I´m at one spot. Sooner or later I´m still connected but no services nor sites will load.

I shut wifi down and turn it on again. Sometimes it works, sometimes Wifi won´t turn on again. To make it work again, I restart.

Other devices have no issue with my Wifi. I used Ubuntu 16.04 till yesterday. Under Ubuntu je Wifi worked fine. Sometimes i needed to restart networking after waking up my laptop from suspension, but that was just ocassionaly.

Any suggestions? Thanks! Pier

1

The Realtek wireless cards have a sleep mode to save battery when you don't use the net conecction. The vendor has a poor support to Linux drivers, so you can try to disable the sleep mode with the next trick.

Open a terminal and execute:

echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

Reboot your system. If it don't solved your problem, you can use some of the forked drivers like:

lwfinger at github.com

  • It doesn't work for me. Do you use RTL8723be on Loki? – efkan Dec 22 '16 at 7:50
  • @efkan , try changing your antenna selection with: echo "options rtl8723be ant_sel=2 fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf – bitseater Dec 22 '16 at 17:18
  • Thank you. But I had tried a lot of things. Unfortunately github.com/lwfinger/rtlwifi_new/issues/184 – efkan Dec 22 '16 at 17:57
  • @efkan , can you share the output for the following command? lsmod | grep rtl – bitseater Dec 22 '16 at 18:08
  • rtl8723be 94208 0 btcoexist 180224 1 rtl8723be rtl_pci 28672 1 rtl8723be rtlwifi 77824 3 btcoexist,rtl_pci,rtl8723be mac80211 737280 3 rtl_pci,rtlwifi,rtl8723be cfg80211 565248 3 wl,mac80211,rtlwifi btrtl 16384 1 btusb bluetooth 520192 31 bnep,btbcm,btqca,btrtl,btusb,hci_uart,rfcomm,btintel – efkan Dec 22 '16 at 18:29
0

I use this one with all Ubuntu based Distros and it has worked every time. I tried it on Loki but couldn't manage to get it done. I don't know if it was because they removed the debi or something.

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms linux-firmware
sudo reboot now

If you make it work I'm sure it'll help you, I'm currently using it on Linux Mint 18 and it Works absolutely PERFECTLY. BTW, if you manage to get it to work can you please tell me how? :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.