There was no .bashrc or .bash_profile in my home folder. I created a new file and put inside my aliases. They don't work, terminal ignores everything. Why?

2 Answers 2


There must be some configuration issues, as there is a .bashrc and a .profile file in a default user home directory.

You can check the default settings files in /etc/skel.

Or you might want to create a new test user to play around with settings, hack together a .bashrc and a .profile files and copy them to your user home once it works as you want it to work.


Below there is a link which contains a source.

git bashrc source

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.