This question already has an answer here:

just installed my third machine with Elementary OS but AppCenter results are blank when searching or following categories. Wifi connection is fine - I've tried apt-get remove --purge and reinstalling but it's still blank. Any help please?

marked as duplicate by Lewis Goddard Sep 25 '16 at 15:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


If you run AppCenter without running sudo apt update at least one time, it shows up empty. As you might have guessed, run sudo apt update and then open up AppCenter and things should work.

This is a known bug on high importance and with a $30 bounty.


A possible solution could be:

After removing appcenter reboot your computer.

Then install appcenter again (do not forget sudo apt-get update after installing).

If not solved try rebooting again after sudo apt-get update and check if this last reboot solved the problem.

This is a known bug on high priority and with a $50 bounty.

Not the answer you're looking for? Browse other questions tagged or ask your own question.